Inbox with all read mail appears empty

RESOLVED INCOMPLETE

Status

--
major
RESOLVED INCOMPLETE
9 years ago
5 years ago

People

(Reporter: win.srisk, Unassigned)

Tracking

({ux-consistency})

Trunk
ux-consistency

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100825 Thunderbird/3.1.3

When all mails in the inbox are read, and the 'unread' filter button in the quick filter bar is clicked on and off, the Inbox shows empty. When I enter just a dot (".") in the filter pane of the quick filter bar al messages re-appear. (i think).

Searching for messages in the inbox results in finding the messages. So they are still there, but not shown in the Inbox pane.

Reproducible: Always

Steps to Reproduce:
1. mark all messages in inbox 'read'
2. select 'unread' filter button, and click it off
3.
Actual Results:  
mails in Inbox not visible

Expected Results:  
all mails in inbox visible
(Reporter)

Comment 1

9 years ago
I forgot to mention this inbox is in Local Folders
Does this also happens in safe-mode (http://support.mozillamessaging.com/en-US/kb/Safe+Mode) ?
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
(Reporter)

Comment 3

9 years ago
Yes, right after opening in safe mode only unread mail are visible.
place a dot in the quick filter field and the read messages are visible again in the inbox.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ux-consistency
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk
This sounds like something I've heard of before; are you guys (ludo/wayne) aware of any other bugs / getsatisfactions on with similar reports of errors relating to quickfilter appearing to latch its constraints or otherwise cause misleading message display until the search parameters are changed in a fashion that should not cause more things to be displayed...?  (Thanks!)

Comment 5

9 years ago
I've heard GS reports of things that might be the same, but hadn't thought that it might be quickfilter latching onto unread.
(In reply to comment #4)
> This sounds like something I've heard of before; are you guys (ludo/wayne)
> aware of any other bugs / getsatisfactions on with similar reports of errors

in bugs nothings strikes me .
Co van Winsum, are you still seeing this?
Flags: needinfo?(win.srisk)
(Reporter)

Comment 8

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #7)
> Co van Winsum, are you still seeing this?

I have uninstalled a long time ago.
Flags: needinfo?(win.srisk)
(In reply to Andrew Sutherland (:asuth) from comment #4)
> This sounds like something I've heard of before; are you guys (ludo/wayne)
> aware of any other bugs / getsatisfactions on with similar reports of errors
> relating to quickfilter appearing to latch its constraints or otherwise
> cause misleading message display until the search parameters are changed in
> a fashion that should not cause more things to be displayed...?  (Thanks!)

no
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.