JM: Zooming in and out doesn't work on Bing Maps

VERIFIED WORKSFORME

Status

()

Core
JavaScript Engine
VERIFIED WORKSFORME
8 years ago
8 years ago

People

(Reporter: alex_mayorga, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre

With javascript.options.methodjit.content true zooming doesn't work.
With javascript.options.methodjit.content false zooming works.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.bing.com/maps/
2. Try to zoom in/out with the buttons or scroll wheel
Actual Results:  
Nothing happens.

Expected Results:  
Map zooms in/out.

http://forums.mozillazine.org/viewtopic.php?p=9893741#p9893741
Any Error/Web Console Output?
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Summary: Zooming in and out doesn't work on Bing Maps → JM: Zooming in and out doesn't work on Bing Maps
Version: unspecified → Trunk
blocking2.0: --- → ?

Comment 2

8 years ago
If you switch from the "road" view to the "aerial" view (or vice versa), the zoom level gets updated.

Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100916 Firefox/4.0b7pre ID:20100916041016
(Reporter)

Comment 3

8 years ago
(In reply to comment #1)
> Any Error/Web Console Output?

Error Console (loading)
Errors
Lots of 
Error: [Exception... "'Error: Cannot get outputNode by id' when calling method: [nsIConsoleListener::observe]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "<unknown>"  data: no]

Warnings (tried to remove duplicates)

Warning: Error in parsing value for 'filter'.  Declaration dropped.
Source File: http://www.bing.com/maps/
Line: 11
Warning: Error in parsing value for 'background'.  Declaration dropped.
Source File: http://www.bing.com/maps/
Line: 11
Warning: Unknown property 'zoom'.  Declaration dropped.
Source File: http://www.bing.com/maps/
Line: 11
Warning: Error in parsing value for 'border'.  Declaration dropped.
Source File: http://www.bing.com/maps/
Line: 44
Warning: Error in parsing value for 'filter'.  Declaration dropped.
Source File: http://www.bing.com/maps/
Line: 44
Warning: Unknown property 'zoom'.  Declaration dropped.
Source File: http://www.bing.com/maps/
Line: 44
Warning: Unknown property 'a'.  Declaration dropped.
Source File: http://www.bing.com/maps/
Line: 504
Warning: Error in parsing value for 'display'.  Declaration dropped.
Source File: http://www.bing.com/maps/
Line: 0
Warning: Selector expected.
Source File: http://www.bing.com/maps/
Line: 0
Warning: Error in parsing value for 'filter'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'user-select'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Error in parsing value for 'filter'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'text-overflow'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Error in parsing value for 'filter'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'zoom'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Expected declaration but found '*'.  Skipped to next declaration.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown pseudo-class or pseudo-element 'ms_pseudoHover'.  Ruleset ignored due to bad selector.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Error in parsing value for 'display'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'text-overflow'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property '-moz-opacity'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Expected end of value but found '1px'.  Error in parsing value for 'border-top'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Expected color but found 'auto'.  Expected end of value but found 'auto'.  Error in parsing value for 'border'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'user-select'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'behavior'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'scrollbar-base-color'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'scrollbar-arrow-color'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'scrollbar-face-color'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'scrollbar-track-color'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'scrollbar-3dlight-color'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'scrollbar-shadow-color'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'scrollbar-darkshadow-color'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1
Warning: Unknown property 'scrollbar-highlight-color'.  Declaration dropped.
Source File: http://st1.maps.live.com/css/bin/20100909.1531/en/delayed.css
Line: 1


Pressing <Alt> to show the Menu seems to trigger the zoom in/out.

In Web Console I see this when the zoom doesn't work:
12:19:21.838: Network: POST http://www.bing.com/maps/default.aspx/ToCosmos [HTTP/1.1 200 OK 106ms]

In Web Console I see this when I press <Alt> and the zoom in/out triggers:
12:19:27.307: Network: GET http://ecn.t0.tiles.virtualearth.net/tiles/r00?g=557&mkt=en-us&lbl=l1&stl=h&shading=hill&n=z [HTTP/1.1 200 OK 186ms]
(Reporter)

Comment 4

8 years ago
Last message is using Mozilla/5.0 (Windows NT 6.0; rv:2.0b7pre) Gecko/20100916 Firefox/4.0b7pre ID:20100916041016

There are also some of these in Messages:
CoCreateInstance() FAILED.
Confirmed, pressing the Alt does trigger the Zoom.  Interesting that the zoom-slider on the left side moves but the map does not zoom till you press the Alt key. 

Setting to NEW
Tested just now with the latest hourly that contains the latest TM/JM merge into m-c. 

cset: http://hg.mozilla.org/mozilla-central/rev/8745a2a64e23
Status: UNCONFIRMED → NEW
Ever confirmed: true
No load at all here. Just a blank page and a favicon.

cset: http://hg.mozilla.org/mozilla-central/rev/5b4969afa033

I tried all variations, MethodJIT on/off, D2D on/off, D3D9 on/off. No difference.
Loads now, but the bug symptoms above are now reproducible.

Turning off MethodJIT makes the map zoom work again.

http://hg.mozilla.org/mozilla-central/rev/268ef4ccb5ff
This works again on tm-tip, likely bug 597378.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 597378
(Reporter)

Comment 9

8 years ago
WFM albeit slow on Mozilla/5.0 (Windows NT 6.0; rv:2.0b7pre) Gecko/20101004 Firefox/4.0b7pre ID:20101004041645
Status: RESOLVED → VERIFIED
Resolution: DUPLICATE → WORKSFORME

Updated

8 years ago
blocking2.0: ? → betaN+
You need to log in before you can comment on or make changes to this bug.