Backspace and insertion within a contentEditable pre behaves incorrectly

RESOLVED FIXED

Status

()

Core
Editor
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Zach, Assigned: Away for a while)

Tracking

1.9.2 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 240933], URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9

See the attached URL for a working example of the problem which appeared in Firefox 3.6.9.

If a <pre> has contentEditable=true, deleting the first character on a line will bring that line up to the previous line.  Similarly, trying to enter a character with the caret at the beginning of a blank line will actually add the character to the next line.

The demo url is the best explanation of this.

Reproducible: Always

Steps to Reproduce:
1. Click inside a contentEditable div
2. Delete the first character of any line
Or
3.  Add a character at the beginning of a blank line.
Actual Results:  
Deleting the first character of a line moves the rest of the line to the end of the previous line.

Adding a character to the beginning of a blank line actually adds it to the beginning of the next line.

Expected Results:  
Characters should be inserted and deleted without changing surrounding lines.
Seems to be WFM on Trunk on WinXP (Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100913 Firefox/4.0b6pre ID:20100913041656).
Component: General → Editor
Product: Firefox → Core
QA Contact: general → editor
Version: unspecified → 1.9.2 Branch
(Assignee)

Comment 2

7 years ago
This has been fixed on trunk by some of the patches that I landed as part of the work in bug 240933.
Assignee: nobody → ehsan
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Depends on: 240933
Resolution: --- → FIXED
Whiteboard: [fixed by bug 240933]
You need to log in before you can comment on or make changes to this bug.