Need external RenderDocument API for embedding

RESOLVED FIXED

Status

()

Core
Layout
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: tatiana, Assigned: tatiana)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Created attachment 475637 [details] [diff] [review]
patch

In qt embedding we should be able to render document to an external surface.
We need to add shell->RenderDocument wrapper to nsIDOMWindowUtils, because GetShell is internal API and it's not possible to use it from external embedding library.
(Assignee)

Updated

8 years ago
Attachment #475637 - Flags: review?(roc)
Why is it not possible to use GetShell? It's inline.

Comment 2

8 years ago
It seems that the size of nsIDocument is different if you use MOZILLA_INTERNAL_API or something like that. Besides which we really don't want people using nsIDocument out of libxul.
(Assignee)

Comment 3

8 years ago
Created attachment 475723 [details] [diff] [review]
patch

updated uuid
Assignee: nobody → tanya.meshkova
Attachment #475637 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #475723 - Flags: review?(roc)
Attachment #475637 - Flags: review?(roc)
Comment on attachment 475723 [details] [diff] [review]
patch

I think patch is pretty safe, and useful for embedders, and native extensions.

Can we get it in?
Attachment #475723 - Flags: approval2.0?
http://hg.mozilla.org/mozilla-central/rev/bc10c72eb8f1
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 460073
So... the change to nsIDOMWindowUtils is WRONG.  Very very wrong.  If you need to add a method to an IDL interface like this, you should make it noscript and notxpcom, but tossing it in a C++ block means that XPConnect will be confused about what the vtable looks like, and if anyone is foolish enough to add things after your code, or to inherit from this interface, calling things will jump to the wrong methods and crash.

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

7 years ago
Comment 7 was fixed by bug 605999.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.