Clobber at the end of a try server build to improve end-to-end times

RESOLVED DUPLICATE of bug 712206

Status

Release Engineering
General
P4
normal
RESOLVED DUPLICATE of bug 712206
8 years ago
2 months ago

People

(Reporter: jhford, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [buildfaster:?][waittimes])

Because we know that we are clobbering try server builds, we should clobber at the end of the build instead of at the beginning (or do both, making one trivially short).  If we were to do this, we would improve our push to test results available time.  This should not have an effect on the time of the build job so it shouldn't hurt our build wait times.

The main drawback here is that we wouldn't save the build directory.  I don't know how big of a concern this is because the slave will pick up a new job right after reboot which will do a clobber.  If this is a real concern, we could gate the clobber at the end of the build on a file being present on the filesystem.  If we made sure that buildbot.tac was called buildbot.tac before the second clobber, we could roughly duplicate current behaviour.

Comment 1

8 years ago
(In reply to comment #0)
> Because we know that we are clobbering try server builds, we should clobber at
> the end of the build instead of at the beginning (or do both, making one
> trivially short).

As we discussed elsewhere, it behooves us to do both (just in case), but yes, the one at build start should be essentially a no-op.
we could also do this for nightlies
OS: Mac OS X → All
Hardware: x86 → All
(In reply to comment #2)
> we could also do this for nightlies

We already do actually, to free up the space for other builds.

Updated

8 years ago
Blocks: 598175

Updated

8 years ago
Priority: -- → P4
Whiteboard: [waittimes]

Updated

7 years ago
Blocks: 712206
alternately we could clobber before starting buildbot

Updated

5 years ago
Whiteboard: [waittimes] → [buildfaster:?][waittimes]
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering

Updated

4 years ago
No longer blocks: 712206
Depends on: 712206

Updated

4 years ago
Component: Other → General Automation
QA Contact: catlee
Slave pre flight tasks are going to handle this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712206
(Assignee)

Updated

2 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.