Web Console menu item check mark is inconsistent among platforms and broken on Windows

RESOLVED FIXED

Status

DevTools
General
RESOLVED FIXED
8 years ago
8 days ago

People

(Reporter: pcwalton, Assigned: msucan)

Tracking

Trunk
x86
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [patchclean:0925][fixed-in-devtools])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Currently, the Web Console menu item has a check mark next to it on Windows indicating whether it's open or closed (although it's currently broken and it won't update when you close it via the X button). Other platforms, as well as the alt menu, don't have the check mark.

I'm slightly in favor of eliminating the check mark entirely, since as far as I can see the check mark is only used for items under the "View" and "Window" menu, not for "Tools". But I'd be glad to get UI feedback on this. The options are:

(1) Check mark
(2) "Show Web Console" which changes to "Hide Web Console"
(3) No check mark

In any case, the behavior should be fixed on Windows at least. Because this is a glaringly obvious UI issue affecting the main menu on Windows, I'm nominating this as a Firefox 4 blocker.
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
(Reporter)

Updated

8 years ago
Summary: Web Console check mark is inconsistent and broken on Windows → Web Console check mark is inconsistent among platforms and broken on Windows
(Reporter)

Updated

8 years ago
Summary: Web Console check mark is inconsistent among platforms and broken on Windows → Web Console menu item check mark is inconsistent among platforms and broken on Windows
if this is just the App Menu's Web Console menu-item, it's probably a simple fix to update it properly on show/hide.

Updated

8 years ago
blocking2.0: ? → final+

Updated

8 years ago
Blocks: 594225

Updated

8 years ago
Assignee: nobody → mihai.sucan
(Assignee)

Comment 2

8 years ago
Created attachment 478534 [details] [diff] [review]
proposed fix

This is the proposed fix. I suggest we remove the checkbox for the same reasons as you do, but also because the rest of the tools, like Downloads, Error console, or even Preferences ... do not have a checkbox, nor do they have menuitems that change their labels based on state (eg. "Show downloads" and "Hide downloads").

This patch only seems to need to fix the new app menuitem for the Web Console. I couldn't test this patch on my Windows 7 virtual machine, make fails.

Please let me know if other changes are needed. Thanks!
Attachment #478534 - Flags: feedback?(pwalton)
(Assignee)

Updated

8 years ago
Status: NEW → ASSIGNED
Whiteboard: [patchclean:0925]
(Reporter)

Comment 3

8 years ago
Comment on attachment 478534 [details] [diff] [review]
proposed fix

One line patches are delicious.
Attachment #478534 - Flags: feedback?(pwalton) → feedback+
(Assignee)

Comment 4

8 years ago
Comment on attachment 478534 [details] [diff] [review]
proposed fix

Thanks Patrick for the feedback+! Asking for review from Gavin.
Attachment #478534 - Flags: review?(gavin.sharp)
Attachment #478534 - Flags: review?(gavin.sharp) → review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
pushed to devtools,
changeset 7f1425dc04f6.
Whiteboard: [patchclean:0925] → [patchclean:0925][fixed-in-devtools]
Duplicate of this bug: 601514
How is this "chekin-needed" and "uiwanted"?
Version: unspecified → Trunk
good question. removed ui-wanted as I don't think we need that anymore.
Keywords: uiwanted

Comment 9

8 years ago
http://hg.mozilla.org/mozilla-central/rev/e1f7d24bbb1c
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

8 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.