[mobile2] Clicks are broken after trying to zoom in a local tab

VERIFIED FIXED

Status

defect
VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

9 years ago
Posted patch patch (obsolete) — Splinter Review
Steps to reproduce:
1. Open about:home
2. Double-tap
3. Tap a link

Expected results: Link highlights and opens.

Actual results: Nothing happens, or a highlight appears in an odd place and a different link opens.

This is because zooming does not work in local tabs.  This patch simply disabled all zoom operations in local browsers.  This is a temporary band-aid until we fix local zooming.
Attachment #475721 - Flags: review?(mark.finkle)
Assignee

Updated

9 years ago
tracking-fennec: --- → ?
Attachment #475721 - Flags: review+
Assignee

Comment 1

9 years ago
Posted patch patch v2Splinter Review
Rebased against latest mobile2.
Attachment #475721 - Attachment is obsolete: true
Attachment #475724 - Flags: review?(mark.finkle)
Attachment #475721 - Flags: review?(mark.finkle)
Assignee

Updated

9 years ago
Attachment #475724 - Flags: review?(mark.finkle) → review+
Assignee

Comment 2

9 years ago
Pushed to mobile2: http://hg.mozilla.org/users/bstover_mozilla.com/mobile2/rev/ea70f3df7037
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Since we're not zooming into a local tab, verified by clicking on links to remote pages on builds:

Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b6pre) Gecko/20100916 Namoroka/4.0b7pre Fennec/2.0b1pre

and

Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b6pre) Gecko/20100916 Namoroka/4.0b7pre Fennec/2.0b1pre
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.