Links appearing in the url bar are confusing and not helpful

RESOLVED INVALID

Status

()

--
enhancement
RESOLVED INVALID
8 years ago
6 years ago

People

(Reporter: notforyourmail, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100915 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100915 Firefox/4.0b7pre

In the latest minefield build, when you hover over a link, it appears in a confusing interface in the url bar.  The link is highlighted in grey, and sepparated from the current page link with a > graphic.  However, this appears to just be part of the current page link.  It's hard to read.  It's hard to distinguish from the current page.  It cuts off the current page link unnecessarily.  It also cuts off the tail end of the target link, making it very hard to read. This "feature" should be removed.

Reproducible: Always

Steps to Reproduce:
1.  Hover over link
2.  Greyed, hard to read, text appears on the right side of the url bar.
3.  Current page link is partially obscured, target link tail is cut off.
Actual Results:  
Greyed, hard to read, text appears on the right side of the url bar.

Current page link is partially obscured, target link tail is cut off.

Expected Results:  
Target link appears on status bar.  Or, it could appear in the url bar, with easy to read highlighting and background coloring, and an indication that it is the target.  This would *replace* the current page link, not cover part of it.  However, any use of this location to display target links might confuse some users.
Component: General → Location Bar
QA Contact: general → location.bar
Version: unspecified → Trunk
the statusbar will be replaced, so links can't appear there. Now if you have better ideas, you could propose them in mozilla.dev.usability or mozilla.dev.apps.firefox newgroups.
Severity: normal → enhancement
(Reporter)

Comment 2

8 years ago
What is the status bar being replaced with?  I've always thought it worked really well.

Comment 3

8 years ago
I have yet to hear any rationale why status bar will be removed. It's just a really dumb decision all around. There is a reason Firefox users don't switch to Chrome: because they don't like Chrome's UI! That said, even Chrome displays the URL in full like it's supposed to.

Comment 4

8 years ago
I confirm that
Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20101002 Firefox/4.0b7pre ID:20101002041357

Michael, please change platform to "All".

Please anybody add the settings to bring url back to statusbar instead of addressbar.

Comment 5

8 years ago
> Please anybody add the settings to bring url back to statusbar instead of
> addressbar.

Seconding that.

See also bug 610429 and http://firefox.uservoice.com/forums/57440-firefox-4-beta/suggestions/1217833-bring-back-the-status-bar .

Comment 6

8 years ago
Something Chrome did right and Firefox does not is displaying the link URL at a fixed position: having it aligned to the right makes it very hard to see the target URL at a glance.

Please make it possible to display it at the bottom left again, or at least -somewhere- at a fixed position.

Comment 7

8 years ago
For me, displaying links in url bar is clearly a bad idea, but this bug would not be fixed.
But there is an extention that brings status bar back
https://addons.mozilla.org/ru/firefox/addon/status-4-evar/
this is no more default behavior
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.