MIN_INT for preferences module is 1 more than it should be.

RESOLVED FIXED in 1.0

Status

P3
normal
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: erikvvold, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.55 Safari/534.3
Build Identifier: 

http://github.com/erikvold/jetpack-sdk/commit/3c421f62852f8fc424114a9c43f475acd339cee9.patch

Reproducible: Always
(Reporter)

Comment 1

8 years ago
The following is a link to the pull request of github (incase you are not getting notifications): http://github.com/mozillalabs/jetpack-sdk/pull/4
(Reporter)

Updated

8 years ago
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

8 years ago
I'll have to revert the following in my diff, I'll make another afap:
-    if (value > MAX_INT || value < MIN_INT)
+    if ((value > 0 && value > MAX_INT) || value < MIN_INT)

It's pointless.
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Version: Trunk → unspecified
Priority: -- → P1
Target Milestone: --- → 1.0
Priority: P1 → P3
Erik: could you re-submit the pull request? Since we renamed the repo from jetpack-sdk to addon-sdk, the pull request got lost. I'll review it when you do.
(Reporter)

Comment 5

7 years ago
(In reply to comment #4)
> Erik: could you re-submit the pull request? Since we renamed the repo from
> jetpack-sdk to addon-sdk, the pull request got lost. I'll review it when you
> do.

k, I'll do so tonight.
(Reporter)

Comment 6

7 years ago
(In reply to comment #4)
> Erik: could you re-submit the pull request? Since we renamed the repo from
> jetpack-sdk to addon-sdk, the pull request got lost. I'll review it when you
> do.

https://github.com/mozilla/addon-sdk/pull/160
Landed, in https://github.com/mozilla/addon-sdk/commit/005fe6fd40e7509344cc5c8a10d48e8c2aafd230 . I took the liberty of rebasing to current master and adding some extra tests.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.