If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bare CDATA sections now flagged as JavaScript syntax error

RESOLVED DUPLICATE of bug 596502

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 596502
7 years ago
7 years ago

People

(Reporter: kmag, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100916 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100916 Firefox/4.0b7pre                     

Until very recently, bare <![CDATA[]]> sections were allowed outside of other XML or XMLList literals. Now they are flagged as a syntax error. I.e., currently <><![CDATA[]]></> works while <![CDATA[]]> does not, while previously both did.

This happened some time in the past two days, and prior to revision 54133:e45446b74099.

Reproducible: Always

Steps to Reproduce:
Compile any JavaScript code in 1.8 mode with an XML CDATA literal in the top level.

Comment 1

7 years ago
Duplicate of bug 596502 which is itself a duplicate perhaps.
blocking2.0: --- → ?
Depends on: 596580

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 596502
blocking2.0: ? → ---
No longer depends on: 596580
You need to log in before you can comment on or make changes to this bug.