Context menu, Open link in new tab was interchanged

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: kleines_eichhoernchen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

Between version 3.69 and 4.0Beta, the context menu "open link in new tab" and "open link in new window" are interchanged. It's realy annoying

Reproducible: Always
This was done by a Design Decision to further promote Tab Usage amongst other things.

Updated

8 years ago
Duplicate of this bug: 609172

Comment 3

8 years ago
WONTFIX?   intentional change via bug 322736.

Comment 4

8 years ago
As the author of Bug 609172 ---which I originally titled "[Regression] Please Stop Destroying My Muscle Memory"---I believe I said all I could thereby.  Thus have I simply added my vote for this one.

I also cc'd two people who seemed to question Bug 322736:  Mike Connor at Bug 322736 Comment 2; and Gavin Sharp at Bug 322736 Comment 25, who specifically expressed concern as to users' muscle memory.  I'd like them to know that their concerns were well-founded, and this change did indeed bug actual users.  Again, I refer them to what I said at Bug 609172, q.v.  As it seems that the in-the-field experience of a user who registered for Bugzilla just to complain about this bears less weight than an agenda to "promote tabs" (per 322736), at least what I said is good for a laugh.
Muscle memory is a concern, but it isn't the the most important. The change can be upsetting to some users (and some of our changes have been upsetting to me personally in the past), but muscle memory tends to adjust itself pretty quickly if you're willing to let it :)

In this case, the benefits (a more useful position for the frequently used entry) to a majority of users (current and in the future) have been deemed to outweigh the (temporary) unpleasantness for a minority of existing users. These decisions won't ever be able to be made in a way that pleases everyone, unfortunately.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Updated

7 years ago
Duplicate of this bug: 643400
You need to log in before you can comment on or make changes to this bug.