Closed Bug 596952 Opened 9 years ago Closed 9 years ago

about:support, other about:pages are layed out incorrectly sometimes

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(fennec2.0b1+)

VERIFIED FIXED
Tracking Status
fennec 2.0b1+ ---

People

(Reporter: vingtetun, Assigned: mbrubeck)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch Patch (obsolete) — Splinter Review
Steps to reproduce:
 * set about:support as the start page
 * close, then relaunch fennec

Actual result:
 * page is layout on 980px without any scaling
  It sounds like because this is a local page without any viewport

Expected result:
 * page fit completely on the layout


I'm a bit unsure of the solution here, but since when we're switching tab the browser seems to be layout at the innerWidth, i think this can do the job.
Attachment #475819 - Flags: review?(mbrubeck)
Comment on attachment 475819 [details] [diff] [review]
Patch

I don't think we want to take this patch - there seems to be an underlying bug that we should fix instead.
Attachment #475819 - Flags: review?(mbrubeck) → review-
Duplicate of this bug: 596991
From the duplicate bug 596991, this also affects about:fennec.
Blocks: 576192
Summary: about:support is badly layout when use as a start page → about:support, other about:pages are layed out incorrectly sometimes
tracking-fennec: --- → 2.0b1+
Attached patch temporary hackSplinter Review
The underlying bug is that we can't set the scale in local tabs (bug 597081).  If they use the default 980px viewport width, then we fail when trying to zoom them out to fit, resulting in the current incorrect rendering.

I think the idea in Vivien's hack above actually is the best solution for beta 1; here's an implementation that I like better.
Assignee: nobody → mbrubeck
Attachment #475819 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #475962 - Flags: review?(mark.finkle)
Attachment #475962 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/748e503f9ae9

We can remove this hack when bug 597081 is fixed.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Hack seems ok : 
Mozilla/5.0 (Android; Linux armv71; rv2.0b7pre) Gecko/20100917 Firefox/4.0b7pre Fennec/2.0b1pre
Matt, could you create a bug to remove this hack for when bug 597081 is fixed if there isn't one please?
Status: RESOLVED → VERIFIED
It won't be possible to fix bug 597081 without removing this hack, so no separate bug is necessary.  (This hack disabled local tab zooming, and bug 597081 is "Implement local tab zooming.")
You need to log in before you can comment on or make changes to this bug.