-silent and -chrome command line flags are busted in Fennec

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: aakashd, Assigned: mfinkle)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Build Id:
Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b6pre) Gecko/20100916 Namoroka/4.0b7pre Fennec/2.0b1pre

Steps to Reproduce:
1. Go to the App Manager
2. Update to the latest nightly build (i'm using the trunk_multi repo)

Actual Results:
Once the installation is completed in the App manager, Fennec starts up with the app manager in the background.

Expected Results:
Fennec should not start up unless I told it to.
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
When did this start?

Comment 2

7 years ago
http://mxr.mozilla.org/mobile-browser/source/installer/debian/fennec.postinst.in#13
Assignee: nobody → mark.finkle
tracking-fennec: ? → 2.0b2+
We are not handling the -silent flag correctly. BrowserCLH.js has the code
(Assignee)

Updated

7 years ago
Summary: Fennec starts up after installation on the N900 → -silent and -chrome command line flags are busted in Fennec
Created attachment 476316 [details] [diff] [review]
patch

Recent refactors to the commandline handling must have broken the -silent and -chrome cmdline flags.

This patch fixes them
Attachment #476316 - Flags: review?(mbrubeck)
Attachment #476316 - Flags: review?(mbrubeck) → review+
landing for beta 1, since this affects testing too
pushed:
http://hg.mozilla.org/mobile-browser/rev/462d5f00e827
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Still launches during the installing phase:

Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b7pre)Gecko/20100917 Firefox/4.0b7pre Fennec/2.0b1pre
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Naoki - What build did you test? This just landed today (9/17). Did you make a build?
I made a mistake; I missed the timing of the push.  setting back to resolved and will regress next build.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

7 years ago
verified FIXED on build:

Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b6pre) Gecko/20100920 Namoroka/4.0b7pre Fennec/2.0b1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.