Last Comment Bug 597012 - No release date shown in new about dialog under Linux
: No release date shown in new about dialog under Linux
Status: VERIFIED INVALID
: pp
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 596905
Blocks: 579547
  Show dependency treegraph
 
Reported: 2010-09-16 08:51 PDT by Dave Garrett
Modified: 2010-09-21 10:51 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Dave Garrett 2010-09-16 08:51:55 PDT
Screenshot under Windows 7:
attachment 475863 [details]
My screenshot under Linux (w/ KDE4.4):
attachment 475865 [details]

Both are from the same latest nightly, just different OSes.

Windows has "4.0b7pre (released 09-16-2010)". Linux has just the version.

See also 596905.
Comment 1 :Margaret Leibovic 2010-09-16 15:34:28 PDT
(In reply to comment #0)

> Both are from the same latest nightly, just different OSes.

Did you build it yourself, or get it through the nightly website? If you built it yourself, there won't be a released date.
Comment 2 Dave Garrett 2010-09-16 17:38:47 PDT
I said "latest nightly" and the term "nightly" is usually implied to be one of the Mozilla built nightlies, not self-built. My build is a standard nightly downloaded from Mozilla FTP. Full info:

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-4.0b7pre.en-US.linux-i686.tar.bz2

Mozilla/5.0 (X11; Linux i686; rv:2.0b7pre) Gecko/20100916 Firefox/4.0b7pre
Built from http://hg.mozilla.org/mozilla-central/rev/f38ef1080bfe

This is Kubuntu 10.04 with KDE 4.4 running on an Intel P4 (x86) laptop.

Tested again with the above using a new Firefox profile.
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-09-16 20:22:18 PDT
Hmm... we're using nsIUpdateManager.getUpdateAt(0).buildID. Isn't that the same as navigator.buildID (i.e. the build ID of the currently running build)? I guess the idea is that we only want to show it if it was actually "updated"? The text just says "released", though, so it would be just as (in)accurate for non-updates...
Comment 4 :Margaret Leibovic 2010-09-21 10:45:21 PDT
This bug is invalid now because we got rid of the release date string in bug 596905.
Comment 5 Dave Garrett 2010-09-21 10:51:47 PDT
Verified. Yep, non-issue now.

Note You need to log in before you can comment on or make changes to this bug.