Add an URL field "Discussion link:" in bug page to easilly notice the user that someone proposed to develop the discussion outside of bugzilla

RESOLVED DUPLICATE of bug 533604

Status

()

enhancement
RESOLVED DUPLICATE of bug 533604
9 years ago
9 years ago

People

(Reporter: NicolasWeb, Unassigned)

Tracking

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; fr; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9
Build Identifier: 

Bugzilla lack of a "Discussion" link/tab as wikis does.

It as always been confusing for me (and, I'm not the only one) to know if Bugzilla is for the patching process or both ideas (of improvements, ...) discussion and patching process.

If it's a "tab" it could be intergrated into Bugzilla. If it's a link, then it can link to the related thread in mozilla's google groups.

Reproducible: Always
Reporter

Comment 1

9 years ago
By the way, in this case the "vote" link should be changed :
- moved to the discussion "tab"
- renamed
- deleted

(I personaly use it to follow some bugs ;-))

Comment 2

9 years ago
Not something we want to implement.
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: bz-discussion
Reporter

Comment 3

9 years ago
Ok about Bug 79534, but my thought wasn't exactly this one (it cover more, aka 2 solutions) : I've update the title.

A Section "Discussion link :" could be added in bug page to easilly notice the user that someone proposed to develop the discussion outside of bugzilla (as for https://bugzilla.mozilla.org/show_bug.cgi?id=574688#c129).

It could be between "Additional Comments:" and the new-comment-form to keep aware people that someone else decided to link the discussion outside of bugzilla (newsgroup, forum,...).

It could works like the "Blocks" or "See Also" (with the remove check box, for this one) component of a bug page.
If needed the theming could warn the user : the "Discussion link :" could be in a red box.

With that feature, the discussion is not always outside of Bugzilla but is easilly noticeable to users before sending an answer.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Bugzilla lack of a "Discussion" link/tab as wikis does → Add a form-control "Discussion link:" in bug page to easilly notice the user that someone proposed to develop the discussion outside of bugzilla
Reporter

Comment 4

9 years ago
In the way it is done now, it's hard to :
- know if there is a thread for external discussion
- if there is one, to know where it is in the comments (it could be totaly surrounded)
- to find and follow all developpments of the bug (answering in the bug without knowing bout the external discussion)

(Sorry for having made 2 comments not in one...)

Comment 5

9 years ago
Well, you are just asking for a field to put a URL in it, pointing to some
external page or website. We don't plan to hardcode such fields. The plan is to
use custom URL fields, so that each installation can add then if needed only.
So bug 533604 is the way to go.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 533604
Reporter

Comment 6

9 years ago
Ok, so Where should I move this bug to ask for this not in bugzilla core, but in the implementation avaible in bugzilla.mozilla.org ? (and then I'll make this one blocking/depending on bug 533604)

By the way, bug 79534 is very old and as of my comment https://bugzilla.mozilla.org/show_bug.cgi?id=79534#c11 the real use/behavior have changed, so we might consider this feature (as a custom URL field if it's what we prefer for bugzilla.mozilla.org).

Thanks
(and thanks to having cc me in bug 533604 ;-))
Reporter

Updated

9 years ago
Summary: Add a form-control "Discussion link:" in bug page to easilly notice the user that someone proposed to develop the discussion outside of bugzilla → Add a custom URL field "Discussion link:" in bugzilla.mozilla.org bug page to easilly notice the user that someone proposed to develop the discussion outside of bugzilla

Comment 7

9 years ago
(In reply to comment #6)
> Ok, so Where should I move this bug to ask for this not in bugzilla core, but
> in the implementation avaible in bugzilla.mozilla.org ?

mozilla.org / other b.m.o issues. Maybe you should file a separate bug as this one was definitely upstream oriented.
Reporter

Comment 8

9 years ago
I've switch back the title to explain why this is, at the end, RESOLVED DUPLICATE

I've filled a new bug 597508 specific to bugzilla.mozilla.org

I had found the mozilla.org component under the "Other" section, but with the description, I understood that "administration" means "for administrator" or "about the administration side of the mozilla.org web sites".
(Me: 1 / Compon. page: 0 :-p)

I should have seen the comment on the description of the Bugzilla product.
(Me: 1 / Compon. page: 1 ;-))
Summary: Add a custom URL field "Discussion link:" in bugzilla.mozilla.org bug page to easilly notice the user that someone proposed to develop the discussion outside of bugzilla → Add an URL field "Discussion link:" in bug page to easilly notice the user that someone proposed to develop the discussion outside of bugzilla
You need to log in before you can comment on or make changes to this bug.