In Session manager i can not save current session. Comes back with, this operation failed due to a file access error:

RESOLVED INVALID

Status

()

Firefox
Session Restore
--
critical
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: ronn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

In Session manager i can not save current session & it will not give me the previous session or restored session when i restart Firefox. The only time the save session works is if i try to save right after i start Firefox. After that i lose what ever i have been working on or browsing. If Firefox crash's the only session it restores is from when i first started that day. Also i noticed that when i come to log back in to my computer that if i check the task manager there is still a Firefox exe running.    

Reproducible: Always

Steps to Reproduce:
1.I try to save current Firefox session comes back with a error
2.
3.
Actual Results:  
This operation failed due to a file access error:
Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISessionStore.getBrowserState]

JS frame :: file:///C:/Documents%20and%20Settings/johnr/Application%20Data/Mozilla/Firefox/Profiles/6q059pwg.default/extensions/%7B1280606b-2510-4fe0-97ef-9b5a22eafe30%7D/modules/session_manager.jsm :: anonymous :: line 3281

Expected Results:  
My current session should be saved

I had been running a older version of both programs from last year not sure what version. Then i updated to Session manager 0.6.8.3 & updated Firefox to 3.6.8
just recently. That's when the problem started

All add-ons except session manager have been disabled.
I'm using the default theme in Firefox 3.6.8
I uninstalled Session Manager & went back to version 0.6.8pre20091226
this version still causes same error

The other thing i have noticed is that after running for a while my cpu usage runs all the way up to a 100% & everything slows down.
Also Firefox will no longer create a crash log to send in when it does crash.
Ronn,
This is a problem with an extension. You should contact the developer If you disable the extension and still have problems.

There is information on the right hand side of the following page with ways to contact him.
https://addons.mozilla.org/en-US/firefox/addon/2324/

Morac,
If this ends up being a bug with sessionstore, just reopen!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.