Status

()

Core
Build Config
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: RyanVM, Assigned: Benjamin Smedberg)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

7 years ago
Somewhere between my build yesterday (http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7cf62a2a821e) and today, pymake was broken when building in js/src.

Starting with checks.cc, errors like the following appear:
c1xx : fatal error C1083: Cannot open source file: 'c:/mozbuild/mozilla-central/objdir-fx/js/src/checks.cc': No such file or directory
(Assignee)

Comment 1

7 years ago
http://hg.mozilla.org/mozilla-central/rev/d28edafb9a84

But from reading it, that patch looks perfectly fine.
Blocks: 558799
(Assignee)

Updated

7 years ago
Duplicate of this bug: 597250
Created attachment 476097 [details] [diff] [review]
Workaround

This will allow pymake builds to go through pending fixes to pymake.
Attachment #476097 - Flags: review?(nnethercote)
Comment on attachment 476097 [details] [diff] [review]
Workaround

r=me if you add something like this before the "Two related functions" paragraph in v8-dtoa/README:

  All the imported files had their .cc extensions changed to .cpp, because the .cc extensions caused problems with pymake builds on Windows.
Attachment #476097 - Flags: review?(nnethercote) → review+
Is this a case of VPATH additions not working and/or Multiple VPATHs? or something else?
Created attachment 476100 [details] [diff] [review]
Workaround updated per njn's comment

bsmedberg is debugging now, so I'm not landing this yet.
(Assignee)

Comment 7

7 years ago
Created attachment 476115 [details] [diff] [review]
Better fix

This is the better fix. I will not have a chance to land this before I leave, and the tree isn't green, so somebody please land this for me!
Assignee: nobody → benjamin
Attachment #476097 - Attachment is obsolete: true
Attachment #476100 - Attachment is obsolete: true
Status: NEW → ASSIGNED
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
I'll check this in once the tree is green.
http://hg.mozilla.org/mozilla-central/rev/150d64f4e03e
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.