Closed Bug 597281 Opened 9 years ago Closed 9 years ago

Cannot pinch to zoom during loading

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set

Tracking

(fennec2.0b1+)

VERIFIED FIXED
Tracking Status
fennec 2.0b1+ ---

People

(Reporter: stechz, Assigned: stechz)

Details

Attachments

(2 files, 1 obsolete file)

Attached patch Patch (obsolete) — Splinter Review
This is because metaData does not have allowZoom before metadata event is received.
tracking-fennec: --- → ?
Attachment #476123 - Flags: review?(mbrubeck)
Attachment #476123 - Flags: review?(mbrubeck) → review+
Add a comment to the code to explain why allowZoom could be undefined
tracking-fennec: ? → 2.0b1+
Attached patch better fixSplinter Review
Comment on attachment 476288 [details] [diff] [review]
better fix

In retrospect, I'll see your comment and raise you a better patch.
Attachment #476288 - Flags: review?(mbrubeck)
Attachment #476123 - Attachment is obsolete: true
Comment on attachment 476288 [details] [diff] [review]
better fix

Yeah, that is nicer.
Attachment #476288 - Flags: review?(mbrubeck) → review+
Actually, I think this would be even better in resetMetadata in content.js.
(In reply to comment #5)
> Actually, I think this would be even better in resetMetadata in content.js.

Err... cancel that, I think your last patch is fine as is.
Comment on attachment 476302 [details] [diff] [review]
only set default metadata in one place

Last one does not work because most of the time metadata is set to {} by content.js.
Attachment #476302 - Flags: review?(mbrubeck)
Attachment #476302 - Flags: review?(mbrubeck) → review+
Pushed: http://hg.mozilla.org/mobile-browser/rev/357a43bbd419
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Flags: in-litmus?
Flags: in-testsuite?
verified FIXED on build:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b7pre) Gecko/20101007 Namoroka/4.0b7pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus?(mozaakash)
litmus testcase created https://litmus.mozilla.org/show_test.cgi?id=13632 to
regression test this bug
Flags: in-litmus?(mozaakash) → in-litmus+
bugspam
Assignee: nobody → ben
You need to log in before you can comment on or make changes to this bug.