If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

timers not working with xpmenus

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
major
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: tracy, Assigned: edburns)

Tracking

({regression})

Trunk
x86
Windows 98
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
seen on windows build 2000-11-10-06-Mtrunk

- open any menu listing with items that have a '>' indicating more choices 
available under that topic

- highlight that topic

expected results:  new drop-down window appears automatically with related items

tested results:  new drop-down window doesn't open

workaround: click on highlighted topic... that opens the new drop down window

Comment 1

17 years ago
Reporter: do you think this is a regression? because assuming I understand you 
this worksforme w/ Komodo w2k.  I suggest you attach a screen capture.
Keywords: regression

Comment 2

17 years ago
*** Bug 59741 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
I see this bug as well with Mozilla 111004 trunk build on NT4.  To reproduce:
Click on the Tasks menu.  Move the mouse over Tools and leave the mouse there as
long as you like.  The Tools submenu will never pop up.  If you then click the
mouse on Tools, the submenu pops up.  Now, after having clicked on Tools and
making the submenu pop up, move the mouse straight up and off the Tools menu
item.  The Tools submenu popup does not go away.

This all worked fine in yesterday's build.  And I am seeing a lot of brokenness
in today's build that looks like it has to do with timers failing to fire properly.

Comment 4

17 years ago
xpt menus .. timeless next time, dupe this to the bug that is in the right
component.

possible to do with the fact that things were being checked in at the time of
building, will check again on respins
Assignee: asa → pinkerton
Component: Browser-General → XP Toolkit/Widgets: Menus
QA Contact: doronr → jrgm
according to sspitzer, this was a regression from edburns
Assignee: pinkerton → edburns
Summary: drop-down menus not unfolding topics with more avaliable '>' → timers not working with xpmenus

Comment 6

17 years ago
the timer issue was checked out, so "fixed"?

Comment 7

17 years ago
updated win2k trunk build does not show this bug. Marking worksforme (but 
reopen, etc. ,etc.).
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

17 years ago
verified fixed windows build 2000-11-13-06-Mtrunk
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.