Closed Bug 597320 Opened 10 years ago Closed 10 years ago

D3D9/D3D10 interop unstable on NVidia Optimus

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- beta7+

People

(Reporter: bas.schouten, Unassigned)

References

Details

Attachments

(1 file)

NVidia Optimus (http://www.nvidia.com/object/optimus_technology.html) is a technology that will provide an NVidia driver which will load and use either the discrete NVidia GPU or an integrated intel GPU.

The devices provided here are obscure (their names do not match with Vendor/DeviceIDs and interoperability is unstable). We currently have no good solutions for using the correct devices or doing something else to get this working. Therefor we abandon D3D9 layers for devices when nvumdshim.dll is detected. We should come up with a better solution, possibly in cooperation with NVidia.
Attachment #476184 - Flags: review?(jmuizelaar) → review+
http://hg.mozilla.org/mozilla-central/rev/8b4601b6daf2
Status: NEW → RESOLVED
blocking2.0: --- → beta7+
Closed: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 597000
You need to log in before you can comment on or make changes to this bug.