Closed Bug 597328 Opened 9 years ago Closed 9 years ago

TabView cannot be closed when opened with an App Tab selected

Categories

(Firefox Graveyard :: Panorama, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 596781

People

(Reporter: whimboo, Unassigned)

Details

(Whiteboard: [mozmill])

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre

If an App Tab is selected in the browser window and TabView is opened, it cannot be closed anymore with the escape key or the exit button.

I think the reason is that app tabs don't get the focus right now and TabView can only be closed with a normal tab selected?

There shouldn't be a difference between normal tabs and app tabs.
Found while running one of our PoC Mozmill tests.
I believe this is due to bug 596781.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 596781
Just a note. Given this bug we still have a normal tab open. Bug 596781 is for a situation when only app tabs are open. So I wonder if we shouldn't mark it dependent. Sorry for some missing steps in comment 0. So here again:

1. Start Minefield with one normal tab open
2. Open a new tab by Cmd/Ctrl+T
3. Pin the blank tab as app tab
4. Enter TabView with Alt/Ctrl+Space
5. Hit shortcut again to leave TabView
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.