Shows wrong tab after switch to app tab

VERIFIED FIXED in Firefox 4.0

Status

defect
P2
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: micmon, Assigned: iangilman)

Tracking

Trunk
Firefox 4.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: https://bugzilla.mozilla.org/show_bug.cgi?id=597358)

- create a few app tabs
- create two tab groups: one empty, one containing at least two tabs
- stwitch to the group containing the two tabs and have one of them open
- open panorama mode
- select some app tab in the *empty* group

=> the empty group opens but still shows the tab that was active before
=> clicking "new tab" here creates a new tab and hides the tab of the other group
I was able to reproduce this on Mac. Assigning to Ian who is all-things-app-tabs. Perhaps this is a dupe.
Assignee: nobody → ian
OS: Linux → All
Priority: -- → P3
Hardware: x86 → All
Duplicate of this bug: 596655
Duplicate of this bug: 595379
Blocks: 597043
Priority: P3 → P2
Target Milestone: --- → Firefox 4.0
This is fixed by the patch for bug 595374.
Status: NEW → ASSIGNED
Depends on: 595374
Whiteboard: https://bugzilla.mozilla.org/show_bug.cgi?id=597358
bug 595374 has landed, so this should be fixed.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified with nightly minefield builds of 20101021
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.