Closed Bug 597378 Opened 10 years ago Closed 10 years ago

Canvas Pinball doesn't work

Categories

(Core :: JavaScript Engine, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- beta7+

People

(Reporter: Myzar74, Assigned: dvander)

References

()

Details

(Keywords: regression, testcase, Whiteboard: fixed-in-tracemonkey)

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100916 Firefox/4.0b7pre
Build Identifier: 

http://ie.microsoft.com/testdrive/Graphics/CanvasPinball/default.html doesn't run it freezes and floods the web console with this error

14:16:52.924: (void 0) is undefined @ http://ie.microsoft.com/testdrive/Graphics/CanvasPinball/assets/box2d2/box2d.js Line: 25

disabling methodjit fixes the problem so it must be a bug with the new JM

Reproducible: Always

Steps to Reproduce:
1. load http://ie.microsoft.com/testdrive/Graphics/CanvasPinball/default.html
2. Run the ball
3. 
Actual Results:  
The demo freezes

Expected Results:  
The demo should run normally
Keywords: regression
Version: unspecified → Trunk
Confirmed. It work if i turn off JM.
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
I can reproduce this on tm-tip, OS X 10.5. Investigating.
blocking2.0: ? → beta7+
Attached file reduced test case
Assignee: general → dvander
Status: NEW → ASSIGNED
The first bad revision is:
changeset:   52525:1fa8cdc8b328
user:        Jan de Mooij
date:        Tue Aug 10 09:40:16 2010 -0700
summary:     [JAEGER] Pop comparison inputs before branching (bug 585915, r=dvander).
Blocks: 585915
Keywords: testcase
OS: Windows 7 → Windows XP
The problem here was that the effect of FrameState::pinReg() was undone by FrameState::pop(), and the pinned registers could easily be clobbered by the subsequent syncing process.

bug 591836 fixed this by making register pinning more robust. Tomorrow I'll verify the pinball site works and checkin the test case.
Duplicate of this bug: 595585
Duplicate of this bug: 596722
Duplicate of this bug: 598460
Can launch the ball but it gets stuck at the top of the alley and doesn't exit.
Comment on attachment 478362 [details]
Pinball Demo - Stuck Ball @ default.html

Testing on today's nightly (20100924). This is the original page I backed up to when I navigated to the demo again dropping the "default.html". If you look at the next image you see where it actually stopped. When I navigated back to this page it moved the ball position down.

Note the arrows graphics in the instructions is cut off on the left and bottom. ALSO, there is no scroll bar even though I'm scrolled down...
The ball gets stuck at top of launch alley as seen. It just hits that flap and stops. The only difference with this page is I dropped the "default.html" from the URL.
Just a shot of the alley, but ball just makes it through, then stops. I didn't depress the plunger all the way to the bottom this time though. Apparently even virtual pinball machines break-down too.
The cause of this bug is known, and is fixed by bug 591836. Unfortunately that can't land yet because it causes the MSVC linker to crash after PGO.
Whiteboard: fixed-in-tracemonkey
Duplicate of this bug: 599568
bug 591836 is FIXED
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Posting here because the js team is on cc , latest windows hourly 

http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1285744013/

after the tm merge is borked, it doesn't start and it's complaining about missing mozjs.dll
Filed bug about it: Bug 600493 .
Depends on: 601109
No longer depends on: 601109
You need to log in before you can comment on or make changes to this bug.