"Related add-ons" on add-on detail

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
P5
enhancement
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: Roberto Bouzout (tito), Unassigned)

Tracking

unspecified
Future

Details

(Whiteboard: [ddn])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: 

Hello, 

This is an enhancement. I want to request to be able to make a list of "related add-ons" on my add-ons detail page.

See: https://addons.mozilla.org/en-US/firefox/addon/86093/

The idea is to show related add-ons as in "Often used with…" but picked by me, manually, without limit.

This is cool because:

 - Will enhance the navigation of the site, by allowing users to see similar add-ons in a non automated way.
 - Will expose other add-ons that may do or complement the functionality of my extension, or maybe the user is trying to find some related but not my.
 - Will remove the crazy redirect to add-ons from same site ( this happens when you build the list of related add-on manually with lists in your add-on's description )
 - Will have better standar presentation for users.

Implementation:

 - I think this list should be managed by the extension author exclusive because:
 - - maybe can be abused by other extension authors or users.
 - - in some situations maybe I don't want to link to other extensions that cause conflicts with my add-on
 - - the add-on undo the feature that my add-on is adding
 - - the add-on has poor performance 
 - - Simply I don't like/support the idea/implementation/add-on or author of the linked add-on.
 - - If lot of users mark as related lots of extensions the list lose the point.
 - - if lot of users mark as related add-ons a lots of extensions maybe you ending implementing some filtering and lose my point of "manually picked".

Regards


Reproducible: Always
(Reporter)

Comment 1

8 years ago
Forget to mention that the original proposal is here
https://forums.addons.mozilla.org/viewtopic.php?f=20&t=698&start=0
Priority: -- → P5
Whiteboard: [ddn]
Target Milestone: --- → Future
Status: UNCONFIRMED → NEW
Ever confirmed: true
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.