Status

()

Core
JavaScript Engine
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: dvander, Assigned: dvander)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Updated

7 years ago
Blocks: 566369
(Assignee)

Updated

7 years ago
Blocks: 604029
(Assignee)

Comment 1

7 years ago
Created attachment 482957 [details] [diff] [review]
fix

iterNext() really wants the iterator to be at sp[-1], rather than fiddle with that and its slow paths, some ops just rearrange the stack.
Attachment #482957 - Flags: review?(dmandelin)
Duplicate of this bug: 604029
Attachment #482957 - Flags: review?(dmandelin) → review+
I summon Andreas.

/be
(Assignee)

Comment 4

7 years ago
Fiddling with the stack here shouldn't affect perf, it's just internal bookkeeping. There's a chance when taking the slow path, there may be more memory shuffling, but not enough to cause concern.
(Assignee)

Comment 5

7 years ago
http://hg.mozilla.org/tracemonkey/rev/11b020daa97e
OS: Linux → All
Hardware: x86_64 → All
Whiteboard: fixed-in-tracemonkey

Comment 6

7 years ago
http://hg.mozilla.org/mozilla-central/rev/11b020daa97e
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.