Firefox adds anchor tags sometimes...

RESOLVED DUPLICATE of bug 324875

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 324875
8 years ago
8 years ago

People

(Reporter: Evan Sharp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

Every now and then, without the page HTML changing, Firefox will add anchor tags around items that have one anchor tag around it. This causes problems with style sheets, making styles not be shown correctly do to the extra tags being placed everywhere. Refreshing the page does if it, most of the time.  I have seen this on a few other pages.  Note: the same/similar code on the same page is no affected (it randomly picks one or more to do this to).  If it is a problem with the HTML, then shouldn't this happen all of the time?

Actual Results shown is HTML being shown (Seen in Firebug and same in Generate Source (From Web Developer Toolbar)(Note: Problem still occurs when Firebug is disabled)

Expected Results shown is HTML (from server/CTRL+U (view page source))

Reproducible: Sometimes

Steps to Reproduce:
1. Go to http://www.biometemerge.com/test/bone-joint/doctors.php
2. If it doesn't appear this time navigate around (do not refresh) and come back to the page (Note: for this example, the link is in 'Our Staff'->'Doctors' in the top header.
3. Repeat a step 2 a few time... it usually will cause the problem.
Actual Results:  
				<div id="left">
					<div class="block">
					
						<a href="doctors_bartholomew.php">
						
							</a><div id="doc_individual_container">
<a href="doctors_bartholomew.php">							
								</a><div id="doc_individual_pic">

<a href="doctors_bartholomew.php">								<img src="images/doc_ind_bartholomew.jpg" title="Dr. Richard Bartholomew">
								</a></div><!-- end doc_individual_pic -->
<a href="doctors_bartholomew.php">								
								</a><div id="doc_individual_txt">
<a href="doctors_bartholomew.php">								</a><h5><a href="doctors_bartholomew.php">Dr. Richard S. Bartholomew<br> Orthopedic Surgeon of the Shoulder and Knee</a></h5>
<a href="doctors_bartholomew.php">								</a></div><!-- end doc_indvidual_text -->
<a href="doctors_bartholomew.php">							
							</a></div><!-- end doc_individual_container -->
<a href="doctors_bartholomew.php">						
						</a>

						
						<div class="clear"></div>
						<a href="doctors_kohen.php" style="text-decoration: none;">
						
							<div id="doc_individual_container">
							
								<div id="doc_individual_pic">
								<img src="images/doc_ind_kohen.jpg" title="Dr. William Kohen">
								</div><!-- end doc_individual_pic -->
								
								<div id="doc_individual_txt">
								<h5>Dr. William Kohen<br> Orthopedic Surgeon of the Hip, Knee and Shoulder</h5>

								</div><!-- end doc_indvidual_text -->
							
							</div><!-- end doc_individual_container -->
						
						</a>
						
						<div class="clear"></div>
						
						<a href="doctors_sanford.php">
						
							</a><div id="doc_individual_container">
<a href="doctors_sanford.php">							
								</a><div id="doc_individual_pic">
<a href="doctors_sanford.php">								<img src="images/doc_ind_sanford.jpg" title="Dr. Brenda Sanford">
								</a></div><!-- end doc_individual_pic -->

<a href="doctors_sanford.php">								
								</a><div id="doc_individual_txt">
<a href="doctors_sanford.php">								</a><h5><a href="doctors_sanford.php">Dr. Brenda Sanford<br> Orthopedic Surgeon of the Foot and Ankle</a></h5>
<a href="doctors_sanford.php">								</a></div><!-- end doc_indvidual_text -->
<a href="doctors_sanford.php">							
							</a></div><!-- end doc_individual_container -->
<a href="doctors_sanford.php">						
						</a>
						
						<div class="clear"></div>
						
					</div><!--  end block -->

					<div class="clear"></div>
				</div><!-- END LEFT CONTENT -->


Expected Results:  
<div id="left">
					<div class="block">
					
						<a href="doctors_bartholomew.php">

						
							<div id="doc_individual_container">
							
								<div id="doc_individual_pic">
								<img src="images/doc_ind_bartholomew.jpg" title="Dr. Richard Bartholomew" />
								</div><!-- end doc_individual_pic -->
								
								<div id="doc_individual_txt">
								<h5>Dr. Richard S. Bartholomew<br /> Orthopedic Surgeon of the Shoulder and Knee</h5>
								</div><!-- end doc_indvidual_text -->

							
							</div><!-- end doc_individual_container -->
						
						</a>
						
						<div class="clear"></div>
						<a href="doctors_kohen.php" style="text-decoration:none">
						
							<div id="doc_individual_container">
							
								<div id="doc_individual_pic">
								<img src="images/doc_ind_kohen.jpg" title="Dr. William Kohen" />
								</div><!-- end doc_individual_pic -->
								
								<div id="doc_individual_txt">

								<h5>Dr. William Kohen<br /> Orthopedic Surgeon of the Hip, Knee and Shoulder</h5>
								</div><!-- end doc_indvidual_text -->
							
							</div><!-- end doc_individual_container -->
						
						</a>
						
						<div class="clear"></div>
						
						<a href="doctors_sanford.php">
						
							<div id="doc_individual_container">

							
								<div id="doc_individual_pic">
								<img src="images/doc_ind_sanford.jpg" title="Dr. Brenda Sanford" />
								</div><!-- end doc_individual_pic -->
								
								<div id="doc_individual_txt">
								<h5>Dr. Brenda Sanford<br /> Orthopedic Surgeon of the Foot and Ankle</h5>
								</div><!-- end doc_indvidual_text -->
							
							</div><!-- end doc_individual_container -->

						
						</a>
						
						<div class="clear"></div>
						
					</div><!--  end block -->
					<div class="clear"></div>
				</div><!-- END LEFT CONTENT -->

Appeared on co-works computer, also Win7 ultimate 64-bit. But not on other co-work's Mac.

Comment 1

8 years ago
I am running into this bug as well, same basic scenario: a <div> inside an <a> tag, and FireFox occasionally decides to wrap each dom element inside the <div> with a mysterious <a> tag.

Comment 2

8 years ago
I notice this situation when <script> tag placed inside <a> tag.

Comment 3

8 years ago
Created attachment 487147 [details]
Shows DOM of document. Multiple <A> tags.

When <A> tag contains <SCRIPT> tag, then DOM model contains several <A> tags.

Comment 4

8 years ago
This is happening to me as well. 

Trying to create an unordered list with styled elements inside of it and it wraps all elements in anchor tags. 

Example: 

<ul>
<li><a href="http://example.com">

<a href="http://example.com"><p class="1"> Some text </p> </a>
<a href="http://example.com"><p class="2"> Other Text </p> </a>
<a href="http://example.com"><p class="3"> Last text </p> </a>

</li>
</ul>

Refreshing will make it bounce around randomly from one element to the next. The initial HTML only contains the first anchor tag and the closing tag but Firefox randomly adds the links around the <P> elements on it's own. 

This does not seem to be a problem in 4 Beta or any other browser.

Comment 5

8 years ago
My favourite dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 324875
You need to log in before you can comment on or make changes to this bug.