Closed Bug 597540 Opened 11 years ago Closed 11 years ago

Dotted borders are slow in painting/scrolling

Categories

(Core :: Layout, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- final+

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: perf, testcase)

Attachments

(1 file)

Attached file testcase
Scrolling with 1px dotted borders is slow and it seems to be getting slower with more recent builds.

See testcase, when pressing the button, the scrolltest starts.

Some numbers I get:
Seamonkey 1.9.1 build from 2010-07-01: 14217ms
Firefox 3.6.8: 35756ms
Minefield from 2010-09-16: 88801ms (this is with d2d enabled)

This is on Windows 7.
blocking2.0: --- → ?
We should fix the regression for final. It's probably a D2D bug. (Can you confirm that performance is better with D2D disabled? If so, move it to Graphics.)
blocking2.0: ? → final+
I don't know (anymore?) to turn off D2D. I've set mozilla.widget.render-mode to 0 and layers.accelerate-all to false and then I restarted, but in about:support Direct2D Enabled is still described as true.
Btw, about:support is the url where I was seeing the performance issue.
The pref is now called gfx.direct2d.disabled
Martijn, can you direct me to that scrolling test bookmarklet of yours?
(In reply to comment #5)
> Is it the one in bug 588402 comment 19?

I think so! Thanks.
Is this the reason about:support is sluggish to scroll?
Yep, changing dotted to solid using firebug brings scrolling to normal responsiveness. I'm on D2D+D3D10 Layers, so depends on Bug 588271?
Bug 588271 will fix this for D2D. Note these dotted borders are also very slow on GDI though, I'm not sure if that will be fixed.
Depends on: 588271
I'm calling this fixed by 588271.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.