Middle click scroller grab keyboard input forever

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Emmanuel Lepage Vallee, Unassigned)

Tracking

({qawanted})

Trunk
x86_64
Linux
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b6pre) Gecko/20100911 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b6pre) Gecko/20100911 Firefox/4.0b6pre

I can't find a bug looking like that, it may be me because I heard others having the problem.

When I activate the middle click "scroller" (the (< ^ >) button) and firefox is loading something (does not happen when everything is loaded), the keyboard stop working in Firefox. Both keyboard shorthcut (Ctrl+A) and keypress, like writing in an <input type="text" /> field or the AwesomeBar. This happen with many tabs and onlt occasionally, but more and more with the "Firefox Panorama" feature, probably as more tabs load simultaneously in the same window.

The only solution is to restart Firefox, losing most of the content (this is a regression from 3.6 too, in 3.6, data were restored fine in those case).

The "scroller" disapear, but the scrolling effect stay on, so I can move the cursor and it will scroll, clicking on links work, but does not free the keyboard or even the scrolling.

Once the bug happen, Firefox because unusable and have to be closed/restarted completely to regain control of the input.

Reproducible: Sometimes

Steps to Reproduce:
0. Enable the scroller in Edit->Preferences
1. Start Firefox
2. Don't wait until the 30+ tabs are loaded
3. Use the middle click button to enable the scroller
4. Do it again until the problem occur or restart step one
Actual Results:  
See the details 

Expected Results:  
1. Release the input so other controls can use them
2. Stop the scrolling operation

This cause minor data loss, so I think it should block 4.0+1 as the software become unusable once this thing happen, I have to tag it critical, it fit the definition.

I use the official Mozilla build, not some crazy self compiled attempt at getting more performances

Updated

7 years ago
Version: unspecified → 4.0 Branch
(Reporter)

Comment 1

7 years ago
Still present in 6.* (A1)
6.* what?
(Reporter)

Comment 3

7 years ago
Firefox 6.* (nightly)

Updated

7 years ago
Version: 4.0 Branch → Trunk
Keywords: qawanted
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.