Closed Bug 597620 Opened 9 years ago Closed 9 years ago

Undoing an install still installs it (though disabled)

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla2.0b7
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: Mathnerd314, Assigned: mossop)

References

()

Details

(Keywords: regression, Whiteboard: [AOMTestday][in-litmus-bug-week])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100917 Firefox/4.0b7pre

Undoing an install should not install the addon. But the current implementation does.

Reproducible: Always

Steps to Reproduce:
1. Install an extension from AMO
2. Go to the addon manager and undo the install
3. Restart Firefox
Actual Results:  
Addon is installed, though disabled

Expected Results:  
Addon is not installed
Whiteboard: [AOMTestday][in-litmus-bug-week]
I would tend to say that this is a recent regression. It was working a while back.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
blocking2.0: --- → ?
blocking2.0: ? → betaN+
Yet another regression from packed xpi installation
Blocks: packedxpi
Assignee: nobody → dtownsend
This covers the backend making it so installs are actually cancelled. Something still messed up in the UI though that I'll take care of in a separate patch.
Attachment #478480 - Flags: review?(robert.bugzilla)
Turns out we've just never supported undoing the install from the search results, works ok from the main list. This fixes it by adding the removeInstall bits that gListView has and also adds tests for both cases.
Attachment #478488 - Flags: review?(bmcbride)
Status: NEW → ASSIGNED
Whiteboard: [AOMTestday][in-litmus-bug-week] → [AOMTestday][in-litmus-bug-week][has patch][needs review Unfocused]
Comment on attachment 478488 [details] [diff] [review]
frontend patch rev 1

>diff --git a/toolkit/mozapps/extensions/test/browser/browser_install.js b/toolkit/mozapps/extensions/test/browser/browser_install.js
>new file mode 100644
>--- /dev/null
>+++ b/toolkit/mozapps/extensions/test/browser/browser_install.js
>@@ -0,0 +1,145 @@
>+/* Any copyright is dedicated to the Public Domain.
>+ * http://creativecommons.org/publicdomain/zero/1.0/
>+ */
>+
>+// Tests the recent updates pane

LIES!
Attachment #478488 - Flags: review?(bmcbride) → review+
Whiteboard: [AOMTestday][in-litmus-bug-week][has patch][needs review Unfocused] → [AOMTestday][in-litmus-bug-week][has patch]
Whiteboard: [AOMTestday][in-litmus-bug-week][has patch] → [AOMTestday][in-litmus-bug-week][has patch][needs-checkin-post-b7]
Fixed:
http://hg.mozilla.org/mozilla-central/rev/7b0845a3717d
http://hg.mozilla.org/mozilla-central/rev/c619eb7a24d0
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Whiteboard: [AOMTestday][in-litmus-bug-week][has patch][needs-checkin-post-b7] → [AOMTestday][in-litmus-bug-week]
Target Milestone: --- → mozilla2.0b8
Target Milestone: mozilla2.0b8 → mozilla2.0b7
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101105 Firefox/4.0b8pre ID:20101105030743
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.