Canceling a pave-over install of an extension shouldn't trigger an available update

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [AOMTestday][in-litmus-bug-week])

(Reporter)

Description

8 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20100917 Firefox/4.0b7pre

When the same extension is getting installed a second time, but the software installation dialog is canceled, the AOM still shows the "An update is available" text and a broken Update button.

Steps:
1. Install an extension
2. Restart the browser
3. Install the same extension again, but cancel the software installation

As long as the same pane of the AOM is open the above mentioned update text and button are displayed. Canceling an add-on installation shouldn't leave any traces back.
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
blocking2.0: ? → betaN+
I'm not seeing this, I suspect it may have been fixed by bug 558134, can you confirm Henrik?
(Reporter)

Comment 2

8 years ago
Yeah, can't reproduce anymore.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.