If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

forwarding mails with attachments takes much longer than in previous versions

RESOLVED INVALID

Status

MailNews Core
Networking: SMTP
RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: diekraha, Unassigned)

Tracking

1.9.2 Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: v.3.1.4, 

when mails with attachments are forwarded to numerous adresses, the time to completion is much longer than in previous version, i.e. up to two minutes. the processs appears to "hang" at completions states higher than 50% (depending on size of attachments ?)

Reproducible: Sometimes

Steps to Reproduce:
1.open mail window
2.select "forward" button
3.enter list of mail adresses
4.start sending
Actual Results:  
the transfer process remains at interim steps (56% or other) for up to two minutes

Expected Results:  
the transfer process is completed within 10-20 seconds

none
> Actual Results:  
> the transfer process remains at interim steps (56% or other) for up to two
minutes

Does mail sending itself complete? What happens after the "up to two minutes"?
Send fails? Or it simply takes longer than you expect?
When did your problem start to occur? After upgrade from Tb 3.1.3 to Tb 3.1.4? 

Does SMTP server use SSL? (SSL/TLS or StartTLS at SMTP setting of Tb)
What is shown at CPU utilization column of Task Manager for System and thunderbird.exe?
Forward only issue? Problem occurs on any large mail, doesn't it?
You can check it by next.
1. Compose a text mail with large attchments, Send Later
2. Sed Unsent Messags, and watch CPU utilization by System/thunderbird.exe
(System is shown name by Win XP. It may be different on Win-2K)

Comment 2

7 years ago
Is the account from which you are trying to forward the original e-mail an
IMAP account? If yes, is offline synchronization enabled?

Right-click on the folder to open its Properties, then see if there is a Synchronization tab, and if yes, if the box in this tab is checked.
(Reporter)

Comment 3

7 years ago
Answer to WADA, 2010-09-19:
The mail sending process is correctly finished.
Observation on CPU activity shows high utilization at "Thunderbird.exe"
Problem occurred right after upgrade from 3.1.3 to 3.1.4
Important: The status of DSL router goes to offline after email process
was started and remains there for many seconds (thunderbird remains at "56%" during this status. After that, the router status goes to online until the same
behavior is repeated and so on. The data rate for uploading is low (300 bps max.) due to local restrictions. Maybe the handshaking betwenn thunderbird and router was modified.
Answer to rsx11m, 2010-09-20:
Sorry, I cannot find any information in the properties concerning IMAP at all.
Regards
(In reply to comment #3)
> Important: The status of DSL router goes to offline after email process
> was started and remains there for many seconds (thunderbird remains at "56%"
> during this status. 
> After that, the router status goes to online until the same behavior is repeated and so on.

diekraha@t-online.de, "What staus at where that is shown by what operation" do you call by "DSL router status of offline or online"?
(Reporter)

Comment 5

7 years ago
The "DSL router" is the device that connects PC-LAN with Internet/TCP/IP/Ethernet network
(In reply to comment #5)

I know hardware of xDSL router and physical connection types of it. I'm asking about "status of online/offline of the xDSL router" you mentioned. Is "status of offline of xDSL router" similar to "power off of xDSL router" and/or similar to "pull off of LAN cable from Ethernet adapter of PC", and does OS/Network modules and Tb automatically detect "offline" status?
(Reporter)

Comment 7

7 years ago
Well, let me explain what I observed: There is a symbol displayed in the taskline at the bottom of desktop screen. The symbol changes to "router not found" during the long "waiting states", i.e. no communication is possible. The symbol resembles a "sandglass, hourglass" sign, possibly indicating a "waiting state"
When the LAN cable is removed, the OS/Netwok modules detect and notify this.
When the router is switched off, a different symbol is displayed
(Reporter)

Comment 8

7 years ago
I forgot to mention: Does SMTP server use SSL? (SSL/TLS or StartTLS at SMTP setting of Tb)?
The server mode selected was "StartTLS if possible".
I'm going to try SSL/TLS
(Reporter)

Comment 9

7 years ago
Hello, can I expect that this problem will be solved by the next version ??

Comment 10

7 years ago
Well, the main problem is still to understand what the problem is you are running into, thus I wouldn't expect it to be solved with the next update unless it was "fixed" by accident (i.e., by solving some other issue).

One question: Do you see the issue /only/ when forwarding messages with attachments or also when sending /new/ messages with large attachments?

There have been some reports where sending with attachments above a certain size causes Thunderbird to hang, but in your case it's completing, just slower than expected. It may nevertheless be an issue with the packet size, thus go into Tools > Options > Advanced > General and click on Config Editor. Copy-paste network.tcp.sendbuffer into the search bar and double-click on the entry to modify it. Reduce from its default 131072 to 16384 and restart Thunderbird after closing the options windows. This was the value indicated in other case to have resolved the hang-with-attachments issue. As a wild guess, maybe that solves your problem as well.

> (comment #3) I cannot find any information in the properties concerning IMAP

You should see this in Tools > Account Settings, Server Settings of the account in question (labeled "Server Type"). For an IMAP folder, the attachment would have to be downloaded from the server first before it can be attached, but this would happen only before the actual sending process begins. Thus, my assumption
here may not be relevant for your case, so no urgent need to look that up.
Component: General → Networking: SMTP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.smtp
Hardware: All → x86
Version: unspecified → 1.9.2 Branch
(Reporter)

Comment 11

7 years ago
Well, reduction of network.tcp.sendbuffer only increased the sending time, I reset to its original value.
This behavior also takes place when sending messages with large attachments.
The server settings are POP, not IMAP.
(Reporter)

Comment 12

6 years ago
Changing over to LINUX, I got rid of this problem, hence status set to "resolved"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.