Open link in new window gets slower and slower

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Christoph, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Halloween2011Bug][CLOSEME 2012-01-01 WFM])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.1.12) Gecko/20100825 Lightning/1.0b1 Mnenhy/0.8.3 SeaMonkey/2.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.1.12) Gecko/20100825 Lightning/1.0b1 Mnenhy/0.8.3 SeaMonkey/2.0.7

After Seamonkey is restarted opening a new link in a new window is very fast but after opening and closing more and more windows it gets slower. After 100 windows it takes several seconds. It happens whenever a new windows is opened through a middle click or ctrl-n.

In practice I have to restart Seamonkey at least every week to get an acceptable performance again.

It happens with all 2.x versions I used.

Reproducible: Always

Steps to Reproduce:
1.Open new windows.
2.Close windows.
3.Repeat steps 1 and 2.
Actual Results:  
Opening a new window takes several seconds.

Expected Results:  
Opening a new windows should always take the same amount of time.
(Reporter)

Updated

9 years ago
Summary: Open link in new windows gets slower and slower → Open link in new window gets slower and slower

Comment 1

8 years ago
Opening looks fine.
Ctrl+N 20 x.

I do see a slowdown on closing.
Ctrl+W 20 - or more - x.
Or more, cause looks like keystoke buffer is being lost (if you're quick enough in your Ctrl+W's).

Possibly attributable to Session Restore or other clean up routines?

Setting browser.sessionstore.resume_from_crash to false showed no change.

Closing the windows is decidedly slower then opening them.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.20pre) Gecko/20110514 Firefox/3.6 SeaMonkey/2.0.15pre

Comment 2

8 years ago
Note: I did this repeatedly.
Opened one original window, Ctrl+N'd 20x, Ctrl+W'd 20x (or more), Ctrl+N'd 20x, Ctrl+W'd 20x ...

Comment 3

7 years ago
WORKSFORME
Tested on 40+, no difference in windows opening speed observed
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111017 Firefox/10.0a1 SeaMonkey/2.7a1

Comment 4

7 years ago
Christoph, could you test against a recent release and see if it is still an issue?
Whiteboard: [Halloween2011Bug][CLOSEME 2012-01-01 WFM]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.