URL Typo in "Firefox 4.0 Information for Add-on Developers"

VERIFIED FIXED in 5.12.1

Status

addons.mozilla.org Graveyard
Developer Pages
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: gekacheka, Unassigned)

Tracking

unspecified
5.12.1

Details

(URL)

(Reporter)

Description

8 years ago
Mistyped URL
- https://developer.mozilla.org/en/Firefox_4.0_for_developers
+ https://developer.mozilla.org/en/Firefox_4_for_developers

Steps to reproduce:
1. goto https://addons.mozilla.org/en-US/firefox/compatibility
2. click "Information for Add-on Developers"
3. after "Information on overall changes in Firefox 4.0 can be found in"
   click "this article".

Actual result:
Redirects to https://developer.mozilla.org/en-US/

Expect result:
Open page at https://developer.mozilla.org/en/Firefox_4_for_developers
I've modified the mistyped MDC page so that it points to the correct one. I'm not sure if this bug can be fixed entirely, because the compatibility pages are designed to work with multiple Firefox versions:

<li>Information on overall changes in %s can be found in <a href="https://developer.mozilla.org/en/%s_for_developers">this article</a>.</li>

It looks like this is the first time that MDC breaks the naming standard, and that the reason the link isn't working.
Target Milestone: --- → 5.12.1
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> I've modified the mistyped MDC page so that it points to the correct one. 

Thanks, that's probably sufficient, though it would be nice if it redirected.
Documentation seems to say it is possible.
http://developer.mindtouch.com/en/kb/Manually_redirect_a_page

> I'm
> not sure if this bug can be fixed entirely, because the compatibility pages are
> designed to work with multiple Firefox versions:
> 
> <li>Information on overall changes in %s can be found in <a
> href="https://developer.mozilla.org/en/%s_for_developers">this
> article</a>.</li>
> 
> It looks like this is the first time that MDC breaks the naming standard, and
> that the reason the link isn't working.

Or maybe the AMO page was written after Firefox 3 was released (2 yrs ago).  

It looks to me like the naming standard of not using ".0" in the number is pretty established on MDC right now, some of the pages haven't been edited recently:
https://developer.mozilla.org/Special:Search?search=firefox+for+developers&type=fulltext&go=Search
I tried using a proper redirect, but it didn't work.
The redirect works fine for me.

And the coding of the link is intentional -- we have to include the full version so things like Firefox 3.5 work, and it's easy to just create a redirect for major versions, as we did with Firefox 3.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified FIXED; spun off bug 604197 to cover the remaining two links that redirect.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.