A link in a nested frameset will freeze browser if targeted at outside frameset

VERIFIED FIXED

Status

()

Core
Layout: HTML Frames
P3
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Jairus Pryor, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Alright, the description wasn't very good... Assume you have a frameset, with 
frames A B and C... Frame B is another frameset, with frames B1, B2, and B3. If 
a link in any of the Bx frames attempts to target frames A, or C, it will 
freeze the browser. It looks like links can only target frames paralell to them 
safely. While it may not be HTML compliant to target other/parent framesets, it 
should be made safe to click on, at least.

In the URL given, this is the case. Three vertical frames (A,B,C), and three 
horizontal ones (in the middle; 1,2,3)... if you click on any of the lower set 
of links (which target B), it'll freeze mozilla... (Nov 5, 2000)

Comment 1

17 years ago
I can't reproduce with URL provided. I would need a simplified test case
provided by the reporter.

Comment 2

17 years ago
Jairus Pryor, like Chris Petersen I cannot reproduce this bug. Do you still see
this problem on the latest build? If yes, we need a simplified testcase where
you can reproduce the problem. Is it due to the frameset created by JavaScript?
(Reporter)

Comment 3

17 years ago
Seems to work in latest build... all is well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 4

17 years ago
Marking verified per last comments
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.