Results for Kraken Test: Very slow script for ai-astar

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
enhancement
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: Leonard Mada, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.0; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Firefox 4.0 beta 6

http://krakenbenchmark.mozilla.com/kraken-1.0/results.html?%7B%22v%22:%20%22kraken-1.0%22,%20%22ai-astar%22:%5B33742,34272,35955,36682,32447,33900,34173,36808,35872,34159%5D,%22audio-beat-detection%22:%5B6758,6728,6788,6730,6774,6804,6880,6796,6763,6875%5D,%22audio-dft%22:%5B6343,6321,6303,6318,6336,6355,6314,6313,6309,6319%5D,%22audio-fft%22:%5B6706,6679,6682,6671,6682,6690,6664,6687,6774,6641%5D,%22audio-oscillator%22:%5B8024,8044,8009,8075,8018,7982,8048,7972,7991,8139%5D,%22imaging-gaussian-blur%22:%5B7083,7097,7100,7093,7108,7043,7107,7095,7126,7106%5D,%22imaging-darkroom%22:%5B2668,2683,2672,2684,2683,2694,2670,2682,2678,2719%5D,%22imaging-desaturate%22:%5B14558,14499,14583,14557,14482,14760,14664,14526,14516,14417%5D,%22json-parse-financial%22:%5B613,607,608,610,608,609,616,612,607,617%5D,%22json-stringify-tinderbox%22:%5B621,617,622,661,621,629,630,632,631,629%5D,%22stanford-crypto-aes%22:%5B1370,1371,1365,1356,1372,1372,1380,1363,1375,1372%5D,%22stanford-crypto-ccm%22:%5B1704,1685,1682,1694,1684,1676,1693,1701,1684,1701%5D,%22stanford-crypto-pbkdf2%22:%5B4628,4590,4569,4571,4628,4601,4574,4584,4610,4634%5D,%22stanford-crypto-sha256-iterative%22:%5B1469,1466,1469,1461,1472,1469,1467,1465,1467,1471%5D%7D


Reproducible: Always

Actual Results:  
ai-astar displays ~3 times the slow-script warning, while imaging--desaturate displayed that warning once. As seen in the results, those 2 tests were indeed much slower than the remaining tests.

Expected Results:  
JS should be enhanced even further. I believe that slower systems may yield better estimates of what is running slow and I am willing to run more comprehensive tests, if available (e.g. what exactly is slow within ai-astar).

My system is an old Athlon 1 GHz + 1.2 GB RAM running Win2k SP4.
The results would include the time it took you to respond to the dialog in the test time....

That said, the tests are clearly running for over 10s for you.  But you're using a pre-Jaegermonkey build, if you're using beta 6.  Would you be willing to try a trunk nightly to see how that does?

Comment 2

6 years ago
Sorry to revive this dead thing, but it should be marked as solved, since the tests (nightly 4-27-12) run at about 200 ms for me. Unless one wants to fix the dialog in some way.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.