Closed Bug 597715 Opened 9 years ago Closed 9 years ago

xpcshell test test_service_sync_checkServerError.js or test_preventive_maintenance.js or test_privatebrowsing.js or test_install.js or test_placesTxn.js crash [@ mozilla::scache::StartupCache::WriteToDisk()]

Categories

(Core :: XPCOM, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla2.0b7
Tracking Status
blocking2.0 --- final+

People

(Reporter: mats, Assigned: benedict)

References

Details

(Keywords: crash, intermittent-failure)

Crash Data

Attachments

(1 file, 1 obsolete file)

xpcshell test test_service_sync_checkServerError.js crash [@ mozilla::scache::StartupCache::WriteToDisk()]

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1284829798.1284831686.22953.gz
Whiteboard: [orange]
Blocks: 438871
blocking2.0: ? → final+
Attached patch cancels timer in destructor (obsolete) — Splinter Review
I think Ehsan probably nailed it here: https://bugzilla.mozilla.org/show_bug.cgi?id=598319#c1, which is most likely the same bug. This one has the blocking marker, though!
Assignee: nobody → bhsieh
Attachment #477380 - Flags: review?(dwitte)
Comment on attachment 477380 [details] [diff] [review]
cancels timer in destructor

>diff --git a/startupcache/StartupCache.cpp b/startupcache/StartupCache.cpp
> StartupCache::~StartupCache() 
> {
>+  if (mTimer) {
>+    mTimer->Cancel();
>+  }
>   // Generally, the in-memory table should be empty here,

Moar newline.

r=dwitte
Attachment #477380 - Flags: review?(dwitte) → review+
Duplicate of this bug: 598319
Attached patch ready to goSplinter Review
this can be checked in once the tree opens.
Attachment #477380 - Attachment is obsolete: true
Possible duplicate bug: bug 592136.
Duplicate of this bug: 592136
Duplicate of this bug: 601017
Summary: xpcshell test test_service_sync_checkServerError.js crash [@ mozilla::scache::StartupCache::WriteToDisk()] → xpcshell test test_service_sync_checkServerError.js or test_preventive_maintenance.js crash [@ mozilla::scache::StartupCache::WriteToDisk()]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1285994847.1286000608.11436.gz

PROCESS-CRASH | e:\builds\moz2_slave\mozilla-central-win32-debug-unittest-xpcshell\build\xpcshell\tests\toolkit\components\downloads\test\unit\test_privatebrowsing.js | application crashed (minidump found)
Operating system: Windows NT
                  5.2.3790 Service Pack 2
CPU: x86
     GenuineIntel family 6 model 30 stepping 5
     4 CPUs

Crash reason:  EXCEPTION_ACCESS_VIOLATION
Crash address: 0xffffffffdddddddd

NEXT ERROR Thread 0 (crashed)
 0  xul.dll!mozilla::scache::StartupCache::WriteToDisk() [StartupCache.cpp:861afa477aba : 359 + 0x23]
    eip = 0x004d4917   esp = 0x0012fb00   ebp = 0x0012fb38   ebx = 0x7ffff000
    esi = 0x00000000   edi = 0x00000000   eax = 0xdddddddd   ecx = 0xdddddddd
    edx = 0xdddddddd   efl = 0x00010212
    Found by: given as instruction pointer in context
Summary: xpcshell test test_service_sync_checkServerError.js or test_preventive_maintenance.js crash [@ mozilla::scache::StartupCache::WriteToDisk()] → xpcshell test test_service_sync_checkServerError.js or test_preventive_maintenance.js or test_privatebrowsing.js crash [@ mozilla::scache::StartupCache::WriteToDisk()]
Summary: xpcshell test test_service_sync_checkServerError.js or test_preventive_maintenance.js or test_privatebrowsing.js crash [@ mozilla::scache::StartupCache::WriteToDisk()] → xpcshell test test_service_sync_checkServerError.js or test_preventive_maintenance.js or test_privatebrowsing.js or test_install.js crash [@ mozilla::scache::StartupCache::WriteToDisk()]
Duplicate of this bug: 597390
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1286476264.1286478138.19547.gz
Summary: xpcshell test test_service_sync_checkServerError.js or test_preventive_maintenance.js or test_privatebrowsing.js or test_install.js crash [@ mozilla::scache::StartupCache::WriteToDisk()] → xpcshell test test_service_sync_checkServerError.js or test_preventive_maintenance.js or test_privatebrowsing.js or test_install.js or test_placesTxn.js crash [@ mozilla::scache::StartupCache::WriteToDisk()]
I'm up next after dwitte in landing queue, and I can land this bug's patch if dwitte isn't already planning on doing so.
(In reply to comment #13)
> I'm up next after dwitte in landing queue, and I can land this bug's patch if
> dwitte isn't already planning on doing so.

Actually, dwitte's at lunch, so I'm cutting ahead of him in the landing queue. :)

I'm not sure if he was planning on landing this, so I went ahead with it, to get this bug's randomorange-stoppage in the tree on the sooner side.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
Target Milestone: mozilla2.0b8 → mozilla2.0b7
Crash Signature: [@ mozilla::scache::StartupCache::WriteToDisk()]
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.