Closed Bug 597742 Opened 9 years ago Closed 9 years ago

intermittent timeout of modules/plugin/test/crashtests/522512-1.html | timed out waiting for reftest-wait to be removed (after onload fired)

Categories

(Core :: Plug-ins, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: dbaron, Assigned: benjamin)

References

Details

(Keywords: intermittent-failure)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1284843145.1284843847.3155.gz
Rev3 Fedora 12x64 mozilla-central debug test crashtest [testfailed]

s: talos-r3-fed64-016
REFTEST TEST-UNEXPECTED-FAIL | file:///home/cltbld/talos-slave/mozilla-central_fedora64-debug_test-crashtest/build/reftest/tests/modules/plugin/test/crashtests/522512-1.html | timed out waiting for reftest-wait to be removed (after onload fired)
REFTEST TEST-UNEXPECTED-PASS | file:///home/cltbld/talos-slave/mozilla-central_fedora64-debug_test-crashtest/build/reftest/tests/modules/plugin/test/crashtests/522512-1.html | assertion count 0 is less than expected 4 assertions


I also note that this test is named 522512-1 but was for bug 552512.
Looks like this is correlated with failures in test_painting and test_flush_on_paint? I.e., when the screensaver is running?

Karl, what's the latest on that issue?

Maybe we should add something to the reftest framework so that we do some kind of check to see whether triggering an invalidate leads to a corresponding paint; if it doesn't, we assume a screensaver is running and don't run tests that depend on painting being triggered?
(In reply to comment #2)
> Looks like this is correlated with failures in test_painting and
> test_flush_on_paint? I.e., when the screensaver is running?
> 
> Karl, what's the latest on that issue?

I think jhford is on it.
Depends on: 585286
Whiteboard: [orange] → [orange][screensaver]
s: talos-r3-snow-040
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/mozilla-central_snowleopard_test-crashtest/build/reftest/tests/content/xul/document/crashtests/583230.xul | timed out waiting for reftest-wait to be removed (after onload fired)

Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test crashtest on 2010/09/20 08:02:06

REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/mozilla-central_snowleopard_test-crashtest/build/reftest/tests/content/xul/document/crashtests/583230.xul | timed out waiting for reftest-wait to be removed (after onload fired)
comment #12 through comment #4 were caused by changeset 16d5ab7e1e47 which was backed out in changeset a3e98dfdd557
Bug 585286 was fixed today, which should help this (given that it is marked [scrensaver]).
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1286016301.1286017423.18170.gz
Linux comm-central-trunk debug test crashtest on 2010/10/02 03:45:01
This doesn't seem to be correlated with screensaver bugs any longer.

The commands to fix bug 585286 are running on crashtest machines.
Whiteboard: [orange][screensaver] → [orange]
Duplicate of this bug: 606096
I have removed this test entirely in bug 596451 on the maple branch: the test makes no sense once we have async painting, and it assumes that we repaint every time, which is no longer the case.
Assignee: nobody → benjamin
http://hg.mozilla.org/mozilla-central/rev/671bd739dbff
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.