testcase URL specified appears to pass, but outputs javascript error

VERIFIED INVALID

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Matt, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Using the 20001110 linux build, load the URL specified.

result: the following is output to stdout:
"JavaScript error:
http://mozilla.org/quality/ngdriver/suites/javascript/nav005.html line 41:
window.opener.document.resultsform has no properties"


I saw a few loosely related solaris bugs, but none that mentioned this testcase
URL specifically.

Comment 1

17 years ago
"window.opener" should just be "opener"

Other errors/warnings on the page:
JavaScript strict warning:
http://mozilla.org/quality/ngdriver/suites/testlib.js line 133: redeclaration of
 var bResult

JavaScript error:
http://mozilla.org/quality/ngdriver/suites/javascript/nav005.html line 41: 
window.opener has no properties

JavaScript strict warning:
http://mozilla.org/quality/ngdriver/suites/javascript/nav005.html line 51: 
assignment to undeclared variable aTestcases

JavaScript strict warning:
http://mozilla.org/quality/ngdriver/suites/testlib.js line 204: assignment to 
undeclared variable failed
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

17 years ago
The testcases under http://mozilla.org/quality/ngdriver/... are not supposed to
be run on their own, they're part of an automated testharnes that sets things up
for the tests to run properly. This bug doesn't show a problem in mozilla so
I'll mark it invalid, if you don't agree please reopen.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

17 years ago
This should be reassigned to whomever maintains those test scripts, since the
other problems reported should be corrected.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 4

17 years ago
What "other problems" would that be? The opener vs. window.opener is not a
problem, both mean exactly the same thing, I don't see anything but harmless JS
warnings listed here, did I miss something? --> INVALID again. I think
desale@netscape.com owns the testcase so feel free to reassign to him if there's
still a problem with the testcase.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID

Comment 5

17 years ago
VERIFIED invalid
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.