Closed Bug 597791 Opened 9 years ago Closed 9 years ago

When MOZ_MEDIA isn't set, the build is broken

Categories

(Core :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b8

People

(Reporter: mounir, Assigned: mounir)

References

Details

Attachments

(2 files, 2 obsolete files)

MOZ_MEDIA is defined if --enable-raw OR --enable-ogg OR --enable-webm OR --enable-wave.

nsEventListenerManager.cpp:477 tries to use NS_MOZAUDIOAVAILABLE outside of a MOZ_MEDIA ifdef.

Build with: --disable-raw --disable-ogg --disable-webm --disable-wave to reproduce
Attached patch Patch (obsolete) — Splinter Review
The patch just add 2 ifdef MOZ_MEDIA directives
Attachment #489468 - Flags: review?(ted.mielczarek)
Attached patch Patch (obsolete) — Splinter Review
Sorry, I've uploaded the wrong patch
Attachment #489468 - Attachment is obsolete: true
Attachment #489469 - Flags: review?(ted.mielczarek)
Attachment #489468 - Flags: review?(ted.mielczarek)
Comment on attachment 489469 [details] [diff] [review]
Patch

You want a content or media peer to look at this, this is slightly out of my experience.
Attachment #489469 - Flags: review?(ted.mielczarek)
Comment on attachment 489469 [details] [diff] [review]
Patch

I think Olli might be appropriate.
Attachment #489469 - Flags: review?(Olli.Pettay)
The event listener manager part is ok, but I think the content sink should work
the same way even without MOZ_MEDIA.

Ehsan should know more since he fixed Bug 598090.
Yes, the content sink needs to work even if MOZ_MEDIA is not defined.
You can just remove the content sink part of this patch.  I'm addressing that in bug 606109.
Depends on: 606109
Comment on attachment 489469 [details] [diff] [review]
Patch

r=me for the EventListenerManager part
Attachment #489469 - Flags: review?(Olli.Pettay) → review+
r=smaug
Attachment #489469 - Attachment is obsolete: true
bug 514437 is going to move progress to nsGkAtoms even if MOZ_MEDIA is disabled. I don't think it will cost to do that in that bug thus fixing the compilation issue.
Assignee: nobody → mounir.lamouri
Status: NEW → ASSIGNED
Attachment #490384 - Flags: review?(Olli.Pettay)
Attachment #490384 - Flags: review?(Olli.Pettay) → review+
Pushed:
http://hg.mozilla.org/mozilla-central/rev/8774ecf70aa3
http://hg.mozilla.org/mozilla-central/rev/1d6823f0c00f

With a=bustage
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
You need to log in before you can comment on or make changes to this bug.