"window.navigator.plugins[i].name" returns plugin filename instead of plugin name.

VERIFIED FIXED in M8

Status

()

P3
major
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: desale, Assigned: serhunt)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
"window.navigator.plugins[i].name" returns plugin filename instead of plugin
name.
If we try to get plugin name using javascript command
"window.navigator.plugins[i].name", it returns plugin filenames instead of
plugin names.

Product: Seamonkey [Apprunner/viewer]
Build: 05-04-08
OS: windows-95.

Steps to Reproduce:
1] Please copy HTML code I'm providing.
2] Save it as HTML file and open this HTML file in apprunner as well as viewer.
3] This file lists all the names of available plugins on the screen.

Expected Results: It should list all plugin names.

Actual Results: It lists all plugin filenames.

Code:

<html>
<head>
<title>Test Page</title>
</head>

<body >
<form name="workform">
<SCRIPT LANGUAGE="JavaScript1.1">
document.writeln("<h3>");
document.writeln("List of Plugin Names");
document.writeln("</h3>");
var len = window.navigator.plugins.length;
var i=0;
while (i<len){
document.writeln(i+1 +"]");
document.writeln(window.navigator.plugins[i].name);
document.writeln("<br>");
i++
}

</SCRIPT>
</form>
</body>
</html>

End of Code.
(Reporter)

Updated

20 years ago
QA Contact: 3849 → 4616
(Reporter)

Comment 1

20 years ago
Changing QA Contact to myself.

Updated

20 years ago
Assignee: amusil → beard
Target Milestone: M8

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
Assignee: beard → amusil
Status: ASSIGNED → NEW

Comment 2

20 years ago
This code is in plugins now.

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Comment 3

20 years ago
Fixed 6.4.99, 3:30PM.
(Reporter)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 4

20 years ago
I checked this bug again with todays build.
Build: 1999-06-08-08. [Apprunner/Viewer]

This bug still seems to be there. Its still returning plugin filenames instead
of plugin names. Reopening bug.

Comment 5

20 years ago
How are you testing this?
(Reporter)

Comment 6

20 years ago
Using the testcase I provided.
All I'm doing is just using command "window.navigator.plugins[i].name" in a loop
till i=0 becomes i= window.navigator.plugins.length.

So it should print all the names of available plugins. Instead it's printing all
available plugin filenames.
Basically window.navigator.plugins[i].name is returning the same value as
window.navigator.plugins[i].filename.

Here is example comparison of results I'm getting and expected results.
[Considering, plugins installed on my machine]

Expected Results:

List of Plugin Names

1] CorporateTime vCalendar Plug-in
2] RealPlayer(tm) LiveConnect-Enabled Plug-In (32-bit)
3] QuickTime Plug-In
4] Netscape Default Plug-in
5] Java Plug-in 1.3 for Netscape Navigator
6] Java Plug-in 1.3 for Netscape Navigator
7] LiveAudio
8] NPAVI32 Dynamic Link Library
9] Headspace Beatnik Player Stub V1.0.0.1
10] Shockwave for Director
11] Shockwave Flash 2.0

Actual Results:

List of Plugin Names

1] C:\PROGRAM FILES\NETSCAPE\COMMUNICATOR\PROGRAM\plugins\npvcal32.dll
2] C:\PROGRAM FILES\NETSCAPE\COMMUNICATOR\PROGRAM\plugins\Npra32.dll
3] C:\PROGRAM FILES\NETSCAPE\COMMUNICATOR\PROGRAM\plugins\Npqtw32.dll
4] C:\PROGRAM FILES\NETSCAPE\COMMUNICATOR\PROGRAM\plugins\npnul32.dll
5] C:\PROGRAM FILES\NETSCAPE\COMMUNICATOR\PROGRAM\plugins\npjava12.dll
6] C:\PROGRAM FILES\NETSCAPE\COMMUNICATOR\PROGRAM\plugins\npjava11.dll
7] C:\PROGRAM FILES\NETSCAPE\COMMUNICATOR\PROGRAM\plugins\npaudio.dll
8] C:\PROGRAM FILES\NETSCAPE\COMMUNICATOR\PROGRAM\plugins\npavi32.dll
9] C:\PROGRAM FILES\NETSCAPE\COMMUNICATOR\PROGRAM\plugins\NPBeatSP.dll
10] C:\PROGRAM FILES\NETSCAPE\COMMUNICATOR\PROGRAM\plugins\Np32dsw.dll
11] C:\PROGRAM FILES\NETSCAPE\COMMUNICATOR\PROGRAM\plugins\NPSWF32.dll

This is with todays builds.

Updated

20 years ago
Resolution: FIXED → ---

Comment 7

20 years ago
Clearing Fixed resolution.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

20 years ago
Just checked in a fix. Please verify.
(Reporter)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 9

20 years ago
I checked this with builds 07-02-10. I'm afraid that its still not working. It
still returns plugins filenames instead of names.
Reopening bug.
(Assignee)

Comment 10

20 years ago
Could you please try at least 07-03-99? The latest sweetlou build from 07-02-99
has a timestamp 10:55. I did it well after noon.
(Reporter)

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
(Reporter)

Comment 11

20 years ago
Yeah its working fine with 07-03-08 builds. Sorry for reopening bug and not
checking it with later builds. Thought since its fixed on 07-02, it should work
on those builds. Sorry about confusion.
Marking it fixed and verified.
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

20 years ago
Marking verified.
You need to log in before you can comment on or make changes to this bug.