"position: absolute; left: xx%;" for <span> inserts a linebreak

RESOLVED DUPLICATE of bug 44508

Status

()

Core
Layout
P3
normal
RESOLVED DUPLICATE of bug 44508
18 years ago
16 years ago

People

(Reporter: Koike Kazuhiko, Assigned: Marc Attinasi)

Tracking

Trunk
mozilla1.2alpha
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
if "position: absolute; left: xx%;" is specified for <span> element,
it is displayed at next line.
(Reporter)

Comment 1

18 years ago
Created attachment 19091 [details]
Testcase
I see this on Linis as well (build 2001-01-18-08)
OS: Windows 98 → All

Comment 3

18 years ago
same thing happens for "position:absolute;right:xx;" whether xx is a number or a
percent.
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian

Comment 5

17 years ago
Correct: taking the inline element out of the normal flow for absolute 
positioning should not cause it to be displayed on a new line as if it had been a 
block element.  Reassigned to Layout.
Assignee: pierre → attinasi
Component: Style System → Layout
QA Contact: ian → petersen

Comment 6

17 years ago
There's an example (+screenshot) in the CSS spec:

http://www.w3.org/TR/REC-CSS2/visuren.html#q29

It says:

"""

Relative and absolute positioning may be used to implement change bars, as shown
in the following example. The following document: 

<P style="position: relative; margin-right: 10px; left: 10px;">
I used two red hyphens to serve as a change bar. They
will "float" to the left of the line containing THIS
<SPAN style="position: absolute; top: auto; left: -1em; color: red;">--</SPAN>
word.</P>

might result in something like:

"""

The SPAN should not move down to a new line. Mozilla displayed it correctly
before version 0.9.4 (or 0.9.3 -- I don't remember which of the two).

Updated

17 years ago
Target Milestone: --- → mozilla1.2
likely dup of Bug 44508 ?
Bug 44508 FIXED.
And This problem I can't reproduce with 2002081908-trunk/WinXP.

I think this problem is dup of Bug 44508.
Yes, this is a duplicate of bug 44508 (the inline was positioned as if it were
a block).

*** This bug has been marked as a duplicate of 44508 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.