Link hover in location bar should not appear while scrolling page

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: adw, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
If you leave your cursor on the page and then scroll around (e.g., by using the arrow keys, mouse scroll wheel or trackpad), link targets appear in the location bar if the cursor happens to fall over some.

Link targets should not be shown in the location bar while you're scrolling the page.
(Reporter)

Comment 1

9 years ago
Actually, link targets should pretty much appear only when you move the mouse or focus one with the keyboard.  I mean let's get real y'all.
I think what is described here is that if you scroll, hover a link but the mouse cursor don't stop on it, right?

if that's that I can confirm this on Linux.

STR :
-scroll down a web page
-move your mouse cursor just under a link
-scroll up with keyboard arrow key

This issue don't occurs with the mouse wheel ;-)

Comment 3

9 years ago
I won't consider it a bug if bug 587908 is there to stay.

If you scroll on a page, the cursor changes to the hand whenever it happens to hover over a link and to a caret over text areas. By the rationale of this bug, the cursor should remain an arrow when scrolling and not change into a hand or caret when it hovers over links or text areas.

I do see this becoming a visual annoyance on heavy link pages, but if the behavior is modified to be a delay that would be misconstrued as "slowness".

I'm not completely sure, but I would lean into WONTFIX this.
I like it as it is on Mozilla/5.0 (Windows NT 6.0; rv:2.0b7pre) Gecko/20101006 Firefox/4.0b7pre ID:20101006041601 where this happens scrolling with both the wheel and arrows.
The problem here is that it is really disturbing that something appear in the location bar while the user is just scrolling the page and not stoping with the mouse on the link.
As a user, I behave like "if I move my mouse to hover a link and go to..." so I feel like Fx is doing something wrong if it show something in the location bar while I'm not moving my mouse and that I don't really stop on a link that is hovered by my mouse cursor.

So I really don't think this bug is exclusive to bug 587908 : it couldn't be WONTFIX for the reason of competing with this bug.

To check usability, "ux-control" and "ux-interruption" could be added to keywords by the bug reporter ;-)
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.