[Feature Request] Please add the functionality as provided by the addon 'BarTab' into Firefox by default

VERIFIED DUPLICATE of bug 561149

Status

()

Firefox
Tabbed Browser
--
enhancement
VERIFIED DUPLICATE of bug 561149
8 years ago
8 years ago

People

(Reporter: steve, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.12) Gecko/20100907 Fedora/3.5.12-1.fc12 Firefox/3.5.12
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.12) Gecko/20100907 Fedora/3.5.12-1.fc12 Firefox/3.5.12

The addon Bartab ( https://addons.mozilla.org/en-US/firefox/addon/67651/ ) lets users have finer grained control on when to load/unload content within tabs. It is a essential feature which if added, will greatly enhance the usability of Firefox for power users (who typically might have 50 to 70+ tabs open).

This might also be a 'Advanced' preference. Please do not close this bug, saying that this does not make sense to be builtin since it is already available as an addon until you've tried the addon for a few hours/days first.


Reproducible: Always

Steps to Reproduce:
1. Open firefox, load 70+ tabs, a good number of them with flash
2. Watch firefox memory consumption and general responsiveness (for instance when switching tabs)
3. Install the BarTab addon and restart the browser
4. Follow the steps 1. and 2. and notice the difference
Actual Results:  
Without the abilities of BarTab Firefox feels sluggish

Expected Results:  
Firefox should be the coolest, fastest and most usable browser for anyone out-of-the-box (ie: without the need for installing BarTab)

Comment 1

8 years ago
Thanks for the report however this is a duplicate of a known request.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 561149
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.