Google Calendar has stopped synch'ing in Lightning

RESOLVED DUPLICATE of bug 604227

Status

--
major
RESOLVED DUPLICATE of bug 604227
8 years ago
7 years ago

People

(Reporter: tlabandt, Unassigned)

Tracking

Lightning 1.0b2
x86
Windows XP

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; InfoPath.2; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Mozilla Thunderbird 3.1.4, Lightning 1.0b2

I'm not sure if it is upgrade related, as I recently went to Thunderbird 3.1.4, but my Google Calendar will no longer synch in Lightning.  I disabled Lightning and re-enabled.  No results.  Verified versions and compatability.  Deleted and added Calendar link again.  No results.  Added a new link.  No results.  Continues to say that Calendar is "momentarily unavailable"

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird.
2. View Calendar.
3. "The calendar Google Calendar is momentarily not available"
Actual Results:  
Thunderbird and e-mail appears to be fine, but the calendar is blank and will not bring in my Google Calendar.

Expected Results:  
I think it is as simple as a synch issue.  My Google Calendar is fine within gmail, but no longer displays within Lightning for Thunderbird.  I have been enjoying the convenience of Lightning for months, so I miss having this feature available.

I hope this is not simply an issue of user error, but I was using Thunderbird and Lightning just as I have for months and months when the Calendar function stopped working and became "momentarily not available".  I recall that Thunderbird updated when I opened it within the last few days, but I cannot say for certain that the calendar stopped working after that upgrade.

Comment 1

8 years ago
I am having this same problem. I am using the latest version of Thunderbird (3.1.4) with the latest nightly builds of Lightning and Google Calendar Provider as updated by the Lightning unnoficial updater. I tried uninstalling both lightning and provider and regressing to the current official versions (1.2b and 0.6 or 0.7 I think), but this didn't work either. This has been going on for a few weeks now.

Comment 2

8 years ago
Tbird v 3.1.7 
Lightning v1.0b2
Provider for Google Calendar v0.7

Lightning was working fine. All calendars show up fine on my google calendar page. When I connected to my daughters calendar, all the calendars stopped syncing and reprompted for login/password, which I provided, and the calendar remains totally blank. I re-tested this on my office desktop and as soon as I link to my daughters calendar it breaks.

The only differences between all the other calendars and my daughters are:
1. she only shares busy / available, not the details
2. IPFW has some arrangement with Google to provide their students calendars via student.ipfw.edu, ie. http://www.google.com/calendar/feeds/(student)%40students.ipfw.edu/public/basic

(Note, I have other cals on my Google Cal page that are read only, so that is not it).
Component: Lightning Only → Provider: GData
QA Contact: lightning → gdata-provider
Version: unspecified → Lightning 1.0b2

Comment 3

7 years ago
tlabandt, do you still see this problem?
Whiteboard: [closeme 2012-02-21]

Comment 4

7 years ago
I gave up on Ligntning. I can re-install and test again. Do we want to make it work with Google Calendar or is it a non-issue? What does the group think?

Comment 5

7 years ago
John, I'd be curious to know whether you see this with calendars configured as you described your daughter's.

I'm not quite sure I understand your second sentence in comment 4, however. The point of the GData Provider is that it does work with Google Calendar. This bug is quite old insofar as Lightning and GData are concerned, as some big strides have been made since September of 2010. As calendar sync works for the majority of us using Lightning + GData Provider, getting some follow up from the reporter here is of interest in case there is something unique about the troubled setup.

Comment 6

7 years ago
I have re-installed lightning so it should be the current version. The About box says "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.26) Gecko/20120131 Lightning/1.0b2 Thunderbird/3.1.18".

I deleted all 11 calendars and added them one-by-one again. Two calendars I can chance, and the others I used Calendar / Properties to set to Read Only. Initially all calendars were displayed correctly. I just restarted the computer and looked again and no calendars display.

If you can tell me where to dig I will try to debug. There are no error messages.
The version you are using is very old. Current release is Lightning 1.2 for Thunderbird 10.

Comment 8

7 years ago
Yes, I wonder what the story is. I just installed them from the Ubuntu repository using the Software Center. After I installed all the calendars it worked properly. Later that night when I started it again the calendars were all blank and it kept asking for a password over and over again. I gave up and disabled it.

The About box for TBird says "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.26) Gecko/20120131 Thunderbird/3.1.18". I am also wondering what the Ubuntu Community blog means at https://help.ubuntu.com/community/ThunderbirdNewVersion when it says in Notes: that "Thunderbird 3.1 requires Lightning version 1.0b2."

It seems to me that Ubuntu is out of sync. I uninstalled TBird with the ubuntu Software Center and then extracted the current TBird archive to my home folder and removed Lightning, GData, Enigmail and reinstalled them from the Get Add-Ons interface inside. Most of them forced me to use the command line to remove them with apt-get remove xml-ext-....

Everything except the goggle calendars for IPFW students loaded right. SO here I think is the first decent clue -- the google calendars for both my wife and my daughter are google calendars but they come through https://www.google.com/calendar/feeds/<student-login-name>%40students.ipfw.edu/public/basic

Comment 9

7 years ago
After a little testing the base problem remains. I am thinking the problem is related to the login to fetch the calendar data or the fact that the calendars are shared as "Hide Details" (show only available/busy). In one case lightning did have all the calendars go blank, but they came back ok by closing and reopening the Lightning tab in TBird. 

I have never gotten the google/IPFW calendars to load consistently although on rare occasions they do load. In the failure state Lightning keeps asking for the password.

The calendars that work are from google.com with an XML link like "https://www.google.com/calendar/feeds/<google_login>%40gmail.com/public/basic". The link for the two which do not work is like "https://www.google.com/calendar/feeds/<ipfw_student_login_name>%40students.ipfw.edu/public/basic".

I would feel better about spending time on this if someone else can try to connect to an IPFW student / google calendar and see the same problem.

Comment 10

7 years ago
Is there a build with debug info that I can single-step once it gets stuck?

Comment 11

7 years ago
I know of no specific buid which would allow you to do that, John. You can enable the debug in the error console by setting the following prefs to true:

calendar.debug.log
calendar.debug.log.verbose

Your comment 9 seems to imply a slightly different condition than this bug originally reported. You might want to have a read through the following:

Bug 687415
Bug 465906 (linked through from Bug 604227)
Bug 668321 (not sure how your Google auth is set up; this bug addresses 2-step auth)
Bug 721013

After reviewing those, it may be more appropriate to follow up in one of those than this one, as we can't say whether or not we're syncing when we can't get logged in.

Comment 12

7 years ago
604227 is a newer posting, but it looks like the same bottom line problem. Might as well cost this bug report and de-duplicate.

Comment 13

7 years ago
Noe: Lewis. Because I have seen it sync ONCE and then blank all the calendar data, I am thinking it is a login problem, not a sync problem. The key being the calendar is set to share as free/busy only. I don't see a close bug report button that I can click here. I will continue in Bug 604227. Thanks for taking time to help.

Comment 14

7 years ago
Surely. More than half the battle of squashing bugs is narrowing down symptoms and common factors. Even those of us who are not providing code to the project(s) can participate in offering good feedback and background information. I agree that your issue sounds more along the lines of authentication than some communication failure (or data misfire) later in the process.

Considering the age of this bug, the fact that we don't seem to have anyone else experiencing it - as originally described - , and Wayne's request in comment 3 for follow-up from the reporter, I, too, think this bug should close after giving some time for a response from tlabandt.
(Reporter)

Comment 15

7 years ago
No further comments from me.  Go ahead and close the thread.  I'm just a user who was frustrated with losing my Calendar synch.  I gave up on Lightning and installed Sunbird.

Comment 16

7 years ago
Thread moved to Bug 604227. Please close.

Comment 17

7 years ago
CLOSE DUPLICATE Bug 604227

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: [closeme 2012-02-21]
Duplicate of bug: 604227
You need to log in before you can comment on or make changes to this bug.