Blurry text on some pages when zoomed out in Fennec

VERIFIED FIXED

Status

VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: mbrubeck, Assigned: stechz)

Tracking

Trunk
x86
Linux

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 476884 [details]
screenshot

Steps to reproduce:
1. Open Fennec in portrait orientation (ctrl+shift+q on desktop)
2. Click the "About Mozilla" link at the bottom of the about:home page.
3. Double-tap anywhere to zoom in.
4. Double-tap again to zoom out.

Expected results: Normal rendering
Actual results: Blurry rendering (see attachment)

I can reproduce this consistently in a desktop GTK build from the following revisions.  Sometimes the page is blurry after step 2; it is always blurry after step 4.
mobile-browser: 5024622c731c
mozilla-central: 4097291a632c
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
(Reporter)

Updated

8 years ago
Blocks: 597336
Is this a dupe of bug 597336?
tracking-fennec: ? → 2.0b1+
(Reporter)

Comment 2

8 years ago
I also get blurry text if I open https://bug596895.bugzilla.mozilla.org/attachment.cgi?id=477094 and then click on <a href="#">test 1</a>.

In addition, the tap highlights are then drawn as if the page had scale=1.0, even though the page still appears at the default scale=1.5.
(Assignee)

Comment 3

8 years ago
Created attachment 477180 [details] [diff] [review]
_scale should only be set in _setScale
(Assignee)

Comment 4

8 years ago
Comment on attachment 477180 [details] [diff] [review]
_scale should only be set in _setScale

Another problem is that onLocationChange is *not* the place to get ready for the next pageload. Resetting the scale is now done in pagehide.
Attachment #477180 - Flags: review?(mbrubeck)
(Reporter)

Comment 5

8 years ago
Comment on attachment 477180 [details] [diff] [review]
_scale should only be set in _setScale

Nice catch.
Attachment #477180 - Flags: review?(mbrubeck) → review+
(Assignee)

Comment 6

8 years ago
Pushed http://hg.mozilla.org/mobile-browser/
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified FIXED on builds:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b6pre) Gecko/20100922 Namoroka/4.0b7pre Fennec/2.0b1pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b6pre) Gecko/20100922 Namoroka/4.0b7pre Fennec/2.0b1pre
Status: RESOLVED → VERIFIED
bugspam
Assignee: nobody → ben
You need to log in before you can comment on or make changes to this bug.