test-panel.test:destruct before removed (empty test) failure

RESOLVED FIXED

Status

Add-on SDK
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: myk, Assigned: irakli)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
On Linux, I consistently see the following error when running all tests via |cfx testall| (or running all jetpack-core tests via |cfx test| in the packages/jetpack-core/ directory):

  error: TEST FAILED: test-panel.test:destruct before removed (empty test)

The error doesn't occur when I only run panel tests, however.

Irakli: any thoughts on this one?
(Reporter)

Comment 1

7 years ago
Update: I thought it didn't occur when I only run panel tests, but I'm now seeing it there, and I'm also seeing it on Mac and Windows, for example:

--------------------------------------------------------------------------------(jsdk)host-2-150:jetpack-core myk$ cfx test -b /Applications/Firefox\ 4.0b6.app/ -F panel --verbose
Using binary at '/Applications/Firefox 4.0b6.app/Contents/MacOS/firefox-bin'.
Using profile at '/var/folders/bN/bN4Z5w6UEdC60cFgLX32NU+++TI/-Tmp-/tmp2x3tPO.mozrunner'.
info: executing 'test-panel.testPanel'
info: pass: The panel was loaded.
info: executing 'test-panel.testShowHidePanel'
info: pass: The panel was shown.
info: pass: The panel was hidden.
info: executing 'test-panel.testHideBeforeShow'
info: pass: must not emit show if was hidden before
info: executing 'test-panel.testSeveralShowHides'
error: TEST FAILED: test-panel.testSeveralShowHides (timed out)
info: executing 'test-panel.testContentURLOption'
info: pass: contentURL accepts a string URL.
info: pass: contentURL is a URL object.
info: pass: contentURL stringifies to the string to which it was set.
info: pass: contentURL accepts a URL object.
info: pass: contentURL is a URL object.
info: pass: contentURL stringifies to the URL to which it was set.
info: pass: contentURL accepts a data: URL.
info: pass: contentURL is undefined.
info: pass: Panel throws an exception if contentURL is not a URL.
info: executing 'test-panel.test:destruct before removed'

13 of 15 tests passed.

The following tests failed:
  test-panel.testSeveralShowHides: timed out
  test-panel.test:destruct before removed: empty test

FAIL
Total time: 13.386186 seconds
Program terminated unsuccessfully.
--------------------------------------------------------------------------------
Assignee: nobody → rFobic
Created attachment 477164 [details] [diff] [review]
Fix
Attachment #477164 - Flags: review?(dietrich)
Duplicate of this bug: 598206
Blocks: 596793
Created attachment 477185 [details] [diff] [review]
Missed something in previos one
Attachment #477164 - Attachment is obsolete: true
Attachment #477185 - Flags: review?(dietrich)
Attachment #477164 - Flags: review?(dietrich)
Comment on attachment 477185 [details] [diff] [review]
Missed something in previos one

can you please attach patches with 8 lines of context, and also do a s/where/were/ in the comment just above the first change in this patch, since you're there? r=me, thanks!
Attachment #477185 - Flags: review?(dietrich) → review+
(Reporter)

Comment 6

7 years ago
Fixed by changeset https://hg.mozilla.org/labs/jetpack-sdk/rev/3517e0133425, which includes a fix for one of the two incorrect occurrences of "where" (the other will be fixed by bug 596018).
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

7 years ago
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
You need to log in before you can comment on or make changes to this bug.