Closed Bug 598216 Opened 12 years ago Closed 12 years ago

transition in and out of full screen mode can change size of groups

Categories

(Firefox Graveyard :: Panorama, defect, P3)

x86
Windows XP
defect

Tracking

(blocking2.0 -)

RESOLVED WORKSFORME
Future
Tracking Status
blocking2.0 --- -

People

(Reporter: jbecerra, Unassigned)

References

Details

Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100920 Firefox/4.0b7pre

I noticed that going out of full screen mode changed the size of groupings in Panorama, after having played around in full screen mode for a bit. It's not too difficult to reproduce the problem, but I couldn't get reliable steps.

I tried: open a window, open several tabs, go into Panorama; go into full screen mode, create a group and resize here and there, get out of full screen mode

Roughly, you can see it here: http://screencast.com/t/ZTBiOGQ2MmQ

It's relatively a minor problem. The size of the groups just becomes very small.
Assignee: nobody → mitcho
Priority: -- → P3
Assignee: mitcho → nobody
Removing myself from the bug, but that's just because I'm going to work on       601534 which should (probably) fix this issue.
Suggestion for steps: 

1. Toggle Tab Candy 
2. Make sure you have only one tab group (allows better observation) 
3. Switch from normal mode to full-screen repeatedly (can use F11 shortcut, it doesn't matter witch method is used for toggling between view modes)
This should be fixed in beta 9.
Target Milestone: --- → Firefox 4.0
Blocks: 598154
Duplicate of this bug: 607333
Simple STR:

1) Open panorama with window in full screen mode
2) Resize window to normal mode

Tab group size extends beyond the window.
blocking2.0: --- → ?
bugspam (moving b9 to b10)
Blocks: 608028
bugspam (removing b9)
No longer blocks: 598154
Definitely sucks, but we can ship with it.
blocking2.0: ? → -
Punt
No longer blocks: 608028
Target Milestone: Firefox 4.0 → Future
Verified that this will be fixed once bug 625269 lands.
No longer depends on: 601534
Status: NEW → RESOLVED
Closed: 12 years ago
OS: Windows 7 → Windows XP
Resolution: --- → WORKSFORME
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.