Closed Bug 598234 Opened 9 years ago Closed 9 years ago

[VKB]panning text field into view with software keyboard is broken

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

All
Android
defect
Not set

Tracking

(fennec2.0b1+)

VERIFIED FIXED
Tracking Status
fennec 2.0b1+ ---

People

(Reporter: blassey, Assigned: mbrubeck)

Details

Attachments

(2 files)

Attached image screenshot
I tested with the IME pataches from bug 591047 and got the somewhat broken rendering of the page when the software keyboard popped up.
tracking-fennec: --- → 2.0b1+
OS: Linux → Android
Hardware: x86_64 → All
Might be caused by bug 598391.
Depends on: 598391
Summary: panning text field into view with software keyboard is broken → [VKB]panning text field into view with software keyboard is broken
Assignee: nobody → mbrubeck
This doesn't seem to be affected by bug 598391.
No longer depends on: 598391
vingtetun might want to look at this too, since it's closely related to the code in bug 595233.
This bug is pretty bad :S.  Just wild-ass guessing, maybe some older code intended to offset the distance between focused-field and top-of-screen isn't taking the prefetch displayport region into account?  On google and bing, it appears to me that we would get the right behavior by *not* trying to translate by whatever is being computed.  Not sure if that's helpful.
Attached patch patchSplinter Review
The bad scroll is happening when resizeHandler in browser.js calls scrollIntoView on the #inputhandler-overlay div.  I'm not exactly sure why this scrolls to the bottom of the browser, or why it only happens on Android.  Preventing it fixes the problem, but we should probably follow up to figure out why.

This patch also contains some minor cleanups in FormHelperUI._zoom in browser-ui.js.  None of these change any behavior - they remove some undeclared and unused variables, and simplify a bit of the data flow.
Attachment #478327 - Flags: review?(mark.finkle)
Comment on attachment 478327 [details] [diff] [review]
patch

remove the scrollX and scrollY params from here too:
http://mxr.mozilla.org/mobile-browser/source/chrome/content/bindings/browser.xml#522
Attachment #478327 - Flags: review?(mark.finkle) → review+
(In reply to comment #6)
> remove the scrollX and scrollY params from here too:
> http://mxr.mozilla.org/mobile-browser/source/chrome/content/bindings/browser.xml#522

Done.

Pushed: http://hg.mozilla.org/mobile-browser/rev/b87c09c81023
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b6pre) Gecko/20100927 Namoroka/4.0b7pre Fennec/2.0b1pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b6pre) Gecko/20100927 Namoroka/4.0b7pre Fennec/2.0b1pre
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.