Closed Bug 598306 (SQLite3.7.3) Opened 9 years ago Closed 9 years ago

Upgrade to SQLite 3.7.3

Categories

(Toolkit :: Storage, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b9
Tracking Status
blocking2.0 --- final+
blocking1.9.2 --- -

People

(Reporter: sdwilsh, Assigned: sdwilsh)

References

Details

(Whiteboard: [fixed-in-places])

Attachments

(2 files, 1 obsolete file)

This will fix at least one crasher for us.
Alias: SQLite3.7.3
No longer blocks: 591457
Blocks: 599098
also fixes an assertion and a performance regression (bug 595530, moving a query from 100ms to 12s, other effects are unknown so far).
blocking2.0: --- → ?
3.7.3 is officially out
Attached patch SQLite Changes (obsolete) — Splinter Review
Attached patch Mozilla ChangesSplinter Review
Attached patch SQLite ChangesSplinter Review
non-empty this time...
Attachment #482995 - Attachment is obsolete: true
Depends on: 604232
This is doing great on the places branch plus stuff in comment 1, so blocking final!
blocking2.0: ? → final+
Blocks a beta 8 blocker, approval granted to land.
Blocks: SQLite3.7.4
http://hg.mozilla.org/mozilla-central/rev/40e57eeb5fb0
http://hg.mozilla.org/mozilla-central/rev/588eb6345711
http://hg.mozilla.org/mozilla-central/rev/70d77529b523
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b9
In order to fix bug 595530 on branch, we'll need to take this on 1.9.2.
blocking1.9.2: --- → ?
(In reply to comment #10)
> In order to fix bug 595530 on branch, we'll need to take this on 1.9.2.

Thunderbird would also like to see us get this so that we can then upgrade to 3.7.4 which will fix some significant upgrade crashers.
(In reply to comment #10)
> In order to fix bug 595530 on branch, we'll need to take this on 1.9.2.

That bug is several months old. If it were a true blocker shouldn't it have been nominated before now? Landing a library upgrade a few days before code-freeze doesn't give anyone a great feeling. Can this wait for the next .x release? How big is the set of changes? How long has this upgraded version been tested? About a month of nightlies, but a lot of that was holidays. Did it make it into a beta?
(In reply to comment #12)
> That bug is several months old. If it were a true blocker shouldn't it have
> been nominated before now? Landing a library upgrade a few days before
> code-freeze doesn't give anyone a great feeling. Can this wait for the next .x
> release? How big is the set of changes? How long has this upgraded version been
> tested? About a month of nightlies, but a lot of that was holidays. Did it make
> it into a beta?
It's in beta 9, which is why I hadn't requested it sooner.  I'm fine with waiting to make sure things look OK on beta 9 with it (so it can slip to the next .x release).
I thought these sql landings were considered very low risk given the sql test regime.

comment 11 refers to this blocking landing 3.7.4 bug 618315, which is #3 and #10 thunderbird topcrash for many months. IMO it doesn't need to wait.
(In reply to comment #14)
> I thought these sql landings were considered very low risk given the sql test
> regime.
> 
> comment 11 refers to this blocking landing 3.7.4 bug 618315, which is #3 and
> #10 thunderbird topcrash for many months. IMO it doesn't need to wait.

nevermind. There's zero possibility (I assume) bug 618315 will get into 1.9.2 before firefox 3.6.14 freeze - heck it's not even on trunk.  And from Thunderbird POV getting only 3.7.3 without 3.7.4 into 1.9.2 is of no value. Ludo or standard8 can correct, but I'm not aware of 3.7.3 blocking thunderbird issues other than bug 552050 crasher. 

In light of this, for thunderbird, these bugs need to block 1.9.2.next
blocking1.9.2: ? → .15+
Comment on attachment 482998 [details] [diff] [review]
Mozilla Changes

Requesting approval for 1.9.2 branch - 3.7.3 has been on trunk since beta 9 and Thunderbird need to upgrade to sqlite 3.7.4 (via bug 618315) to fix some crashers.
Attachment #482998 - Flags: approval1.9.2.15?
Attachment #483006 - Flags: approval1.9.2.15?
Also Places has a longstanding performance problem from 1.9.2.10 that we would really like to fix (slowing down locationbar and all history queries)
We're taking bug 618315 for branch instead.
blocking1.9.2: .16+ → -
Attachment #483006 - Flags: approval1.9.2.16? → approval1.9.2.16-
Attachment #482998 - Flags: approval1.9.2.16? → approval1.9.2.16-
You need to log in before you can comment on or make changes to this bug.