Frameset navigate does not work properly after navigate to other document

RESOLVED INVALID

Status

()

Core
Document Navigation
RESOLVED INVALID
8 years ago
2 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

unspecified
mozilla2.0
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100921 Firefox/4.0b7pre ID:20100921041551

Frameset navigate does not work properly after navigate to the other document.

If I *disable* JavaScript then this bug does *not* happen. so I think this bug is completely different to Bug 597315.

Reproducible: Always

Steps to Reproduce A:
1. Start Minefield with new profile
2. Go any page (ex. http://www.mozilla.com/en-US/firefox/central/ )
3. Go URL ( http://www.din.or.jp/~hagi3/JavaScript/JSTips/Default.htm )
4. Click "My Book" in left pane
5. Back 
6. Back,    now, current page is page of step 2
7. Forward  now, current page is page of step 3
8. Forward  Expected current page should be page of step4


Actual Results:
 step 8 fails
 current page is page of step 3

Expected Results:
 step 8 should be work properly
 current page should be page of step4

Steps to Reproduce B:
1. Start Minefield with new profile
2. Go URL ( http://www.din.or.jp/~hagi3/JavaScript/JSTips/Default.htm )
3. Click "My Book" in left pane
4. Go any page (ex. http://www.mozilla.com/en-US/firefox/central/ )
5. Back, Expected current page should be page of step3

Actual Results:
 step 5 fails,
 current page is page of step2

Expected Results:
 step 5 should be work properly
 current page should be  page of step3

Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/f43f9b764efb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre ID:20100817063641
Fails:
http://hg.mozilla.org/mozilla-central/rev/353da09ea0dd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre ID:20100817081027
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f43f9b764efb&tochange=353da09ea0dd

Comment 1

8 years ago
The frameset is created dynamically so it is expected that pages don't go
to session history, because there is no (AFAIK) any reasonable way to
map all the DOM changes to session history.

So the new behavior is expected.

(Note, old gecko and other browsers have problems where because of
dynamic changes frames loaded from session history go to some
wrong frame during restoring from history.)

But, perhaps there are cases when we don't need to be as strict as we are now.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> The frameset is created dynamically so it is expected that pages don't go
> to session history, because there is no (AFAIK) any reasonable way to
> map all the DOM changes to session history.
> 
> So the new behavior is expected.
> 
> (Note, old gecko and other browsers have problems where because of
> dynamic changes frames loaded from session history go to some
> wrong frame during restoring from history.)
> 
> But, perhaps there are cases when we don't need to be as strict as we are now.

Back/Forward navigation works properly till navigate to the other document.
Why navigation history destroy after nvigate the other document?

Comment 3

8 years ago
Because at that point the dynamically created frames go "out-of-scope".

Comment 4

2 years ago
Closing as Invalid based on comment 1 and comment 3.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.